aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:50:53 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:59:18 +0200
commit2c9b8c7766369e2bbb10ce08740081287f7a8856 (patch)
tree657964aa5ad1b72b5177d8e0749f91de4df9349b /testing
parenta0ff250b95d759394ac4c686b01037c1429f3a49 (diff)
downloadaports-2c9b8c7766369e2bbb10ce08740081287f7a8856.tar.bz2
aports-2c9b8c7766369e2bbb10ce08740081287f7a8856.tar.xz
testing/py3-whatever: new aport
https://github.com/Suor/whatever Easy anonymous functions by partial application of operators
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-whatever/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-whatever/APKBUILD b/testing/py3-whatever/APKBUILD
new file mode 100644
index 0000000000..eb87ca5528
--- /dev/null
+++ b/testing/py3-whatever/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-whatever
+_pkgname=whatever
+pkgver=0.5
+pkgrel=0
+pkgdesc="Easy anonymous functions by partial application of operators"
+url="https://github.com/Suor/whatever"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+checkdepends="py3-pytest"
+makedepends="python3-dev"
+source="https://github.com/Suor/whatever/archive/$pkgver/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 -m pytest .
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="eb3f0b9bc63197c1bfdd135a46a597e2f5d6131900910f266c984c1afd901d6cbc8c8ee62397e9af8393bf34beff068dc0007e8b016e70f275e019420f18f6e1 whatever-0.5.tar.gz"