aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-05-07 09:11:24 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-05-30 19:07:49 +0200
commit2ef1089f1f621a720f3acd1469fa4351defc1cfa (patch)
treef21d2bb58136d9710f0bb88a6e9763b571a89c9a /testing
parentbb48794f4df5e5f137812c0ed142ce82e45b2268 (diff)
downloadaports-2ef1089f1f621a720f3acd1469fa4351defc1cfa.tar.bz2
aports-2ef1089f1f621a720f3acd1469fa4351defc1cfa.tar.xz
testing/z3: switch to the CMake buildsystem
Diffstat (limited to 'testing')
-rw-r--r--testing/z3/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/testing/z3/APKBUILD b/testing/z3/APKBUILD
index c55c2a6d07..ccdad0b06e 100644
--- a/testing/z3/APKBUILD
+++ b/testing/z3/APKBUILD
@@ -2,26 +2,29 @@
# Maintainer:
pkgname=z3
pkgver=4.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="Theorem prover from Microsoft Research"
url="https://github.com/Z3Prover/z3"
arch="all"
license="MIT"
depends=""
-makedepends="python2"
+makedepends="cmake"
install=""
subpackages="$pkgname-dev"
source="https://github.com/Z3Prover/$pkgname/archive/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
-prepare() {
- default_prepare
- cd "$builddir"
- python2 scripts/mk_make.py
-}
-
build() {
- cd "$builddir/build"
+ cd "$builddir"
+ mkdir build && cd build
+ cmake -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ..
make
}