aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-04-13 02:17:02 +0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-05-30 09:31:17 +0000
commit51835318c25e73f1bdaf3fd91174a6f55370e713 (patch)
treee1d60599c62cd3076fd2c1a8114108c78a060587 /testing
parent83ad2b3df1058684545fbb84624a7009d32029e1 (diff)
downloadaports-51835318c25e73f1bdaf3fd91174a6f55370e713.tar.bz2
aports-51835318c25e73f1bdaf3fd91174a6f55370e713.tar.xz
testing/seamonkey: Upgrade to 2.49.2
Diffstat (limited to 'testing')
-rw-r--r--testing/seamonkey/APKBUILD25
-rw-r--r--testing/seamonkey/avoid-getcontext-musl.patch15
2 files changed, 26 insertions, 14 deletions
diff --git a/testing/seamonkey/APKBUILD b/testing/seamonkey/APKBUILD
index dd86281480..1e6f377e92 100644
--- a/testing/seamonkey/APKBUILD
+++ b/testing/seamonkey/APKBUILD
@@ -1,23 +1,19 @@
# Contributor: Marc Vertes <mvertes@free.fr>
# Maintainer: Marc Vertes <mvertes@free.fr>
pkgname=seamonkey
-pkgver=2.48
-pkgrel=1
+pkgver=2.49.2
+pkgrel=0
pkgdesc="all-in-one internet application suite"
url="http://www.seamonkey-project.org"
arch="x86_64"
license="MPL"
-depends=""
makedepends="unzip zip gtk+2.0-dev yasm alsa-lib-dev libxt-dev linux-headers
hunspell-dev nspr-dev nss-dev jpeg-dev bzip2-dev zlib-dev libpng-dev
libevent-dev libvpx-dev sqlite-dev libffi-dev pixman-dev python2-dev
icu-dev m4 libxcomposite-dev paxmark autoconf2.13 nss-static
"
-install=""
-subpackages=""
source=" https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/source/seamonkey-$pkgver.source.tar.xz
mozconfig
-
fix-aouth.patch
fix-hunspell.patch
fix-libevent.patch
@@ -30,9 +26,9 @@ source=" https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/
fix-sysctl.patch
fix-system-headers.patch
firefox-gcc-6.0.patch
+ avoid-getcontext-musl.patch
"
-
-builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
build() {
cd "$builddir"
@@ -46,16 +42,16 @@ build() {
CFLAGS="$CFLAGS -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
CXXFLAGS="$CXXFLAGS -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
- make -f client.mk build || return 1
+ make -f client.mk build
}
package() {
cd "$builddir"
- paxmark -msp */dist/bin/xpcshell || return 1
- make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install || return 1
+ paxmark -msp */dist/bin/xpcshell
+ make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
paxmark -msp "$pkgdir/usr/lib/seamonkey-$pkgver/seamonkey" \
"$pkgdir/usr/lib/seamonkey-$pkgver/seamonkey-bin" \
- "$pkgdir/usr/lib/seamonkey-$pkgver/plugin-container" || return 1
+ "$pkgdir/usr/lib/seamonkey-$pkgver/plugin-container"
rm -rf "$pkgdir/usr/lib/seamonkey-$pkgver/dictionaries" \
"$pkgdir/usr/lib/seamonkey-$pkgver/hypenation"
@@ -75,7 +71,7 @@ package() {
rm -f "$pkgdir/usr/lib/pkgconfig/seamonkey-nspr.pc"
}
-sha512sums="b1992a1dbaeb045aea10ff02aa214ec0c1725e3ad0844d2dffd1c0d0c26754fbd98b5fb5df25a2a490ebcb7a47037c61599b0a2e9240338b4e769e529faa33cf seamonkey-2.48.source.tar.xz
+sha512sums="6f69f7fb0a2de8086231b615b62b350edf6c903d2fde90ee4c79e316cfcf5a413097df9afe1397dbfe680e264f6be14c2c147be7ba11c5dbd73a1e9e01b8857e seamonkey-2.49.2.source.tar.xz
ce280a99c6ad15887129819c88bb7ce55a40eaae2fb928c7c9a08aa09dbbe33d9c78a6df1dd0c97869108ff542ea063d1e79d9adb910e0d7ba5c84ebb4e204a1 mozconfig
c3b3b5a32f8672a42c051c03c31761414ce52c4a32258f1c7417af7de891e4b5f620ef2762034a18f84e5c7235559d920963aff0f28c2c1f4ae697a38d49b89c fix-aouth.patch
ea58a2cf58e7d1d99a2346a6977fcb2acff8052e304f9f0d66e24241d77fe352610537c4d2a886b9085b970368dbe46e5011acc210bebcdf22a88a4b5be960b1 fix-hunspell.patch
@@ -88,4 +84,5 @@ fd6b68082843a17a97a09953f24f74e72090acbcd245e8564ffe41ed5cb0a7afbf3dfc653a6e33a5
4a7fae85299969618d729021ed79ab312650419dd849800c4e93c2b78a063a91f4003e2ee66c74abefa28b881376cf78f52e99e5ae3c08b85ba11eeae73a5034 fix-stabs.patch
43e800bdb15a11c21f71d0552ae2e92ad97574eb324f7be75cc92ed98332201386f9c9846d3e5f27b4e71452ffac71ab5b82ffdc2091d6c4830b9cb792bbdde4 fix-sysctl.patch
d65900a74901d0455266342e4efbb655d67c62b52e69f482c33c3da3e24af900a3186f1398b88cccd9e822395480cd4ec4ce0d6053978003911457cacc36f767 fix-system-headers.patch
-664983718ba4ed2588850f499cc7da94f2b35d384b6655b1e5ec118e45e8cbd108aa2b9e04cc4b902f4ddba2e1be2cffb056643e053761bfc6da92c942f30305 firefox-gcc-6.0.patch"
+664983718ba4ed2588850f499cc7da94f2b35d384b6655b1e5ec118e45e8cbd108aa2b9e04cc4b902f4ddba2e1be2cffb056643e053761bfc6da92c942f30305 firefox-gcc-6.0.patch
+c67d6df7ee04539abe126493c2fb61b1377b0cc6d84f660b36ed74e940b575a81830c9d50ce52a70df1ddd1747439b4cef31cbb1642545c176da1d82361fa7da avoid-getcontext-musl.patch"
diff --git a/testing/seamonkey/avoid-getcontext-musl.patch b/testing/seamonkey/avoid-getcontext-musl.patch
new file mode 100644
index 0000000000..5887a7a722
--- /dev/null
+++ b/testing/seamonkey/avoid-getcontext-musl.patch
@@ -0,0 +1,15 @@
+--- a/mozilla/tools/profiler/core/platform-linux.cc
++++ b/mozilla/tools/profiler/core/platform-linux.cc
+@@ -625,10 +625,10 @@
+ {
+ MOZ_ASSERT(aContext);
+ ucontext_t* pContext = reinterpret_cast<ucontext_t*>(aContext);
+- if (!getcontext(pContext)) {
++ /*if (!getcontext(pContext)) {
+ context = pContext;
+ SetSampleContext(this, aContext);
+- }
++ }*/
+ }
+
+ void OS::SleepMicro(int microseconds)