aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorjchipmunk <andrey.pustovetov@gmail.com>2018-03-07 14:35:58 +0300
committerSören Tempel <soeren+git@soeren-tempel.net>2018-05-30 12:22:43 +0200
commit782065ccea8a1415f01f568f5bce411898f4d7fb (patch)
tree2ebf64442bea56dc2795b38d9971047ebd1b3b05 /testing
parent03ad8cc2c10c3da0686b9caf51bb24c98c88db54 (diff)
downloadaports-782065ccea8a1415f01f568f5bce411898f4d7fb.tar.bz2
aports-782065ccea8a1415f01f568f5bce411898f4d7fb.tar.xz
testing/jattach: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/jattach/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/jattach/APKBUILD b/testing/jattach/APKBUILD
new file mode 100644
index 0000000000..431b9064fe
--- /dev/null
+++ b/testing/jattach/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Andrey Pustovetov <andrey.pustovetov@gmail.com>
+# Maintainer: Andrey Pustovetov <andrey.pustovetov@gmail.com>
+pkgname=jattach
+pkgver=1.1
+pkgrel=0
+pkgdesc="JVM dynamic attach utility"
+url="https://github.com/apangin/jattach"
+arch="all"
+license="Apache-2.0"
+options="!check" # upstream doesn't have a test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/apangin/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ install -Dm0755 "$builddir/build/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+sha512sums="9046cf3c4ec5b08ab71a2145b7b777aac7de5453a32cce551dd4daef2a545c32d365c171ce8ad04e3106fea614137a0368d84b8966d796ecb0412810834dd793 jattach-1.1.tar.gz"