aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-06 13:45:48 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-06 13:45:48 +0000
commit8379a21ad0237d51f18ab16913e1a130e4c0845f (patch)
treec4a20f95b8bf628ac28ec776862af19a81dc631c /testing
parent3b99a2c19be326b1630c00dfadced50f2f1b7ecb (diff)
downloadaports-8379a21ad0237d51f18ab16913e1a130e4c0845f.tar.bz2
aports-8379a21ad0237d51f18ab16913e1a130e4c0845f.tar.xz
testing/py-pybles: upgrade to 1.0.13 and modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/py-pybles/APKBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/testing/py-pybles/APKBUILD b/testing/py-pybles/APKBUILD
index be14eb679e..a3058063c2 100644
--- a/testing/py-pybles/APKBUILD
+++ b/testing/py-pybles/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-pybles
_pkgname=Pybles
-pkgver=1.0.1
+pkgver=1.0.13
pkgrel=0
pkgdesc="A Python module to represent tables in the terminal"
url="http://pypi.python.org/pypi/Pybles/"
@@ -15,27 +15,16 @@ install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="97b5063ffcf96d9edc3531ba12ba77da Pybles-1.0.1.tar.gz"
-sha256sums="58df0c91bcc5e913c15c4eb1e88df441543815ab92f049c0daecf97ec93df05a Pybles-1.0.1.tar.gz"
-sha512sums="5a50932e051b2737fad34eb074ce7c04c326d2a2c352645dd19397c99746a2ea1fc4a249e045ff48974cfbd76c5d64e3178f6c87908d3947e4c25e70d04a3f91 Pybles-1.0.1.tar.gz"
+sha512sums="90c6f9b9dc6a87c63162a8ea17c263530acf54df36833e9abdf506d3826fba849fdb0b9666737f4fd0e2ecba7068406b9d58cbdf0acd8a45fef0a2c4a5e5ed28 Pybles-1.0.13.tar.gz"