aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-23 08:29:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-23 08:31:48 +0000
commit862996e46987a654d1d18d0e8fce59b4f56398e6 (patch)
treea9636fd0bf7ad27efa38b7cac0fe2c80f60e5e01 /testing
parent62bce78b03ac257d215b380922a4021c8cbf637a (diff)
downloadaports-862996e46987a654d1d18d0e8fce59b4f56398e6.tar.bz2
aports-862996e46987a654d1d18d0e8fce59b4f56398e6.tar.xz
testing/zfs-grsec: enable on x86 and x86_64 again
Diffstat (limited to 'testing')
-rw-r--r--testing/zfs-grsec/APKBUILD8
-rw-r--r--testing/zfs-grsec/musl-fixes.patch20
2 files changed, 24 insertions, 4 deletions
diff --git a/testing/zfs-grsec/APKBUILD b/testing/zfs-grsec/APKBUILD
index f8a2356ffa..d9d29f7d09 100644
--- a/testing/zfs-grsec/APKBUILD
+++ b/testing/zfs-grsec/APKBUILD
@@ -27,7 +27,7 @@ pkgver=$_kver
pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgdesc="ZFS for Linux"
url="http://zfsonlinux.org"
-arch=""
+arch="x86 x86_64"
license="CDDL"
depends="spl-$_flavor"
depends_dev="glib-dev e2fsprogs-dev util-linux-dev libtirpc-dev
@@ -102,8 +102,8 @@ utils() {
}
md5sums="5b90b3bfcfb9d8e6f0c6ea0061e6b285 zfs-0.6.4.tar.gz
-114cce47477de2f7e0221b595484e618 musl-fixes.patch"
+4ac9600c0cc0ffa70adb957c6ffcafc6 musl-fixes.patch"
sha256sums="fe6a9ad775a5b2ae578c192f17c1981755647ff69ec6bc952e983994572c0c02 zfs-0.6.4.tar.gz
-ef065113892f656afdfb7cae863d9c6b50f6604b86cbc96f57ad0601b66392cf musl-fixes.patch"
+5c65e46bd8b072fa39fd9fd71f0ec52f92a8f083fcb9385d52ed781f77282c79 musl-fixes.patch"
sha512sums="d44174f856628855b1998d014be0573a1641ca6ff67d263f58ff7564a3f7289c066c51c100498ed5c561df2111e04b53c7f2e9958d1cc85fa9291b8f05789319 zfs-0.6.4.tar.gz
-fef928170c5eebe5db1f3fbfc189a2af51f5dc12de7436fa31142daaeebafee536c042ce722e7531420d6a5e479d2e9e3d5da7afb41c7f6509a427524ff3b5dc musl-fixes.patch"
+224ed364a4d924bd9194d82429f0ce316689d09873209a395a76d909a6b8c605dd3130810262fa79d7b6af73da02157377d95d9fe5859dbf70c92503bf77eb53 musl-fixes.patch"
diff --git a/testing/zfs-grsec/musl-fixes.patch b/testing/zfs-grsec/musl-fixes.patch
index 60a5893487..aa4558b1fe 100644
--- a/testing/zfs-grsec/musl-fixes.patch
+++ b/testing/zfs-grsec/musl-fixes.patch
@@ -367,3 +367,23 @@ index 0000000..fb4d2c4
+
#endif
+--- ./cmd/ztest/ztest.c.orig
++++ ./cmd/ztest/ztest.c
+@@ -123,7 +123,7 @@
+ #include <math.h>
+ #include <sys/fs/zfs.h>
+ #include <libnvpair.h>
+-#ifdef __GNUC__
++#ifdef __GLIBC__
+ #include <execinfo.h> /* for backtrace() */
+ #endif
+
+@@ -490,7 +490,7 @@
+ static void sig_handler(int signo)
+ {
+ struct sigaction action;
+-#ifdef __GNUC__ /* backtrace() is a GNU extension */
++#ifdef __GLIBC__ /* backtrace() is a GNU extension */
+ int nptrs;
+ void *buffer[BACKTRACE_SZ];
+