aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-07-10 12:20:26 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-07-10 12:23:19 +0200
commit89114cf202ba14bde2bf58b3f92ada01871104b1 (patch)
treed62313cafd97a80c16d979d408130655c00e30b5 /testing
parent2b5dcf5d9f536bbadbeb48dd1f535cfd1b5bd3af (diff)
downloadaports-89114cf202ba14bde2bf58b3f92ada01871104b1.tar.bz2
aports-89114cf202ba14bde2bf58b3f92ada01871104b1.tar.xz
testing/chromium: multiple fixes
make launcher posix shell compatible add xdg-utils to depends hide api keys for spiders (and the likes) source *.conf so apk new files are not sourced anymore
Diffstat (limited to 'testing')
-rw-r--r--testing/chromium/APKBUILD42
-rw-r--r--testing/chromium/chromium-launcher.sh12
-rw-r--r--testing/chromium/chromium.conf (renamed from testing/chromium/chromium.default)0
-rw-r--r--testing/chromium/google-api.keys10
4 files changed, 38 insertions, 26 deletions
diff --git a/testing/chromium/APKBUILD b/testing/chromium/APKBUILD
index 9d1e454d49..43ffc2e71e 100644
--- a/testing/chromium/APKBUILD
+++ b/testing/chromium/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer:
pkgname=chromium
pkgver=43.0.2357.132
-pkgrel=1
+pkgrel=2
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
arch="x86_64"
license="BSD"
-depends="bash"
+depends="xdg-utils"
depends_dev="alsa-lib-dev libevent-dev libpng-dev jpeg-dev cairo-dev cups-dev
mesa-dev libcap-dev dbus-glib-dev gtk+-dev libxml2-dev freetype-dev
jpeg-dev libxslt-dev libxtst-dev icu-dev flac-dev speex-dev
@@ -24,8 +24,9 @@ options=suid
subpackages="$pkgname-doc"
source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
chromium-launcher.sh
- chromium.default
+ chromium.conf
chromium.desktop
+ google-api.keys
gcc5-fixes.patch
musl-fixes.patch
@@ -41,15 +42,6 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-widevine.patch
"
-##############################################################
-# Please dont use these keys outside of Alpine Linux project #
-# You can create your own at: #
-# http://www.chromium.org/developers/how-tos/api-keys #
-##############################################################
-_google_api_key="-Dgoogle_api_key=AIzaSyCzJlvmpxdW-WUOULKUzow_a98uubu9Ro4"
-_google_default_client_id="-Dgoogle_default_client_id=755214983505-7ramulm762nd0qvsnct55n9kqrd8d65e.apps.googleusercontent.com"
-_google_default_client_secret="-Dgoogle_default_client_secret=TYDXT0NX-GtnRHrb3x4myEQs"
-
_builddir="$srcdir"/$pkgname-$pkgver
case "${CARCH}" in
@@ -105,6 +97,13 @@ build() {
msg "Replacing gyp files"
build/linux/unbundle/replace_gyp_files.py ${use_system} || return 1
+ ##############################################################
+ # Please dont use these keys outside of Alpine Linux project #
+ # You can create your own at: #
+ # http://www.chromium.org/developers/how-tos/api-keys #
+ ##############################################################
+ eval "$(base64 -d < $srcdir/google-api.keys)"
+
msg "Running gyp_chromium"
build/gyp_chromium --depth=. \
${use_system} \
@@ -196,8 +195,8 @@ package() {
ln -sf /usr/lib/$pkgname/chromedriver || return 1
cd "$_builddir"
- install -Dm644 "$srcdir"/chromium.default \
- "$pkgdir"/etc/chromium/chromium.default || return 1
+ install -Dm644 "$srcdir"/chromium.conf \
+ "$pkgdir"/etc/chromium/chromium.conf || return 1
install -Dm644 "$srcdir"/chromium.desktop \
"$pkgdir"/usr/share/applications/chromium.desktop
@@ -214,9 +213,10 @@ package() {
}
md5sums="aba8a1b9945d2c0f203294e43b68cdab chromium-43.0.2357.132.tar.xz
-cdd5fd06a4138a7b6bc954f532193817 chromium-launcher.sh
-c8be238104e757beafaae31e6804421a chromium.default
+b6d015c1da85aa65ee21bc974c7fc7d2 chromium-launcher.sh
+c8be238104e757beafaae31e6804421a chromium.conf
2962ac6259e39a797d441daf43aa49c9 chromium.desktop
+2d2ee5f22d65c756871301b4a407f4ca google-api.keys
96277e7ddc26c8bdd50fb63eff2f4ce0 gcc5-fixes.patch
1b6076a7fac1d056fd6064f5b1b98320 musl-fixes.patch
00ae59dd9d09c60a116fd0133f9f3a60 no-execinfo.patch
@@ -229,9 +229,10 @@ f99bb2ee8947418720a270ffa027c189 musl-sandbox.patch
97b1578585ab600ed9adef4f341ccd80 chromium-system-jinja-r7.patch
de717d6430532f34fe161035dfdafcdf chromium-widevine.patch"
sha256sums="405f52c6649f1d2937952fbcfcd238ba058db7d13edf4705f7027805f3ce1809 chromium-43.0.2357.132.tar.xz
-9bceb14a6c171754b77bcc7e6095285fcb58a9ca10e2e4a9c9e13dc561fc0c01 chromium-launcher.sh
-bc6e879bdf3311394213801a6e6bb1c731be8115624bbcf202bfeacd46b6af87 chromium.default
+89f1eb19d1ed998a190045ea173959f01faee3490d58a6a34ca3fe21228e569f chromium-launcher.sh
+bc6e879bdf3311394213801a6e6bb1c731be8115624bbcf202bfeacd46b6af87 chromium.conf
3ae90cea7503d0039de53448ed112b9bc0cb5a09f6b0045506eb777fc23517e5 chromium.desktop
+267ba8ff50574e51d2582c4fca9b9e14f7225c1fa064d135cbceff9cef2324ac google-api.keys
ee32d8a89cc51cb71a8d4aa82b196b145f43a2fc3ba9687f9c06c053601d5fe7 gcc5-fixes.patch
ac38e2d1238b7062ee8c99ff7772477fa2d5328a750eab47553687e3782dc7a9 musl-fixes.patch
505a55c28e971e067f189e3a1ce697d711cec82a765d81f78eb49ec1f6df56cf no-execinfo.patch
@@ -244,9 +245,10 @@ ea79f9a46116c8b56bbc69d226abd9252e4ae4d946ca695203f2298279cc2211 no-getcontext.
872f5a38d8263b14308bb117828496a4093d0e6ad755d39d2c5e6857314fe071 chromium-system-jinja-r7.patch
1d1ead77250475228524770e57c17282aff9098c5efc3d7719b0df76229b8874 chromium-widevine.patch"
sha512sums="077539f267a8a196a251334546219f3459b30dff3e56d2573b011464cef3b60da49243a123834bd59ad32c78d82b6a90fb2cea95f57bf50a440f689b251a4eba chromium-43.0.2357.132.tar.xz
-f1909314ae74985c85740d26c9bfab694f3202de8ccc392a1c4ec5c8760db21b6cc46146c78a9abebd09e6d24f37e19466f0c4d2d61815400b48d859f8ce154d chromium-launcher.sh
-930f1f390e41c2a986e67a3d7aff45afa116f7c79c4b9f1895225a3851dd12dd2fa2906171ba00f6e43aacfb3d12b20a57934931fcb10a9f88c2048eefc85742 chromium.default
+b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
+930f1f390e41c2a986e67a3d7aff45afa116f7c79c4b9f1895225a3851dd12dd2fa2906171ba00f6e43aacfb3d12b20a57934931fcb10a9f88c2048eefc85742 chromium.conf
e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c chromium.desktop
+2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac google-api.keys
e2390cdeb2a75aad51d5da07819e1375fcf2092535eaa86545b9bc0160eff9e3981f946029ed8fc337df4c56a8b8cc7945821d2636b09e320dea2c8884022a59 gcc5-fixes.patch
febb6a204bcffda8dc3d80e75563710745e383cb30e460db5d8c5ded3d40f8a872461719283260f573be378e085924ddf3af000b0a50b519fafd9f6fc392920e musl-fixes.patch
4f756d3e404033f7a36b38266176b7302f7e2a2e78c9f8b8d362a53a3dbdc675cdaa581393a70c23a29135b34566cf4109513cb13a289dc111bbce65ec065ebd no-execinfo.patch
diff --git a/testing/chromium/chromium-launcher.sh b/testing/chromium/chromium-launcher.sh
index a4fc1a9539..b001d6fe59 100644
--- a/testing/chromium/chromium-launcher.sh
+++ b/testing/chromium/chromium-launcher.sh
@@ -1,10 +1,10 @@
-#!/bin/bash
+#!/bin/sh
# Allow the user to override command-line flags, bug #357629.
# This is based on Debian's chromium-browser package, and is intended
# to be consistent with Debian.
-for f in /etc/chromium/*; do
- [[ -f ${f} ]] && source "${f}"
+for f in /etc/chromium/*.conf; do
+ [ -f ${f} ] && . "${f}"
done
# Prefer user defined CHROMIUM_USER_FLAGS (from env) over system
@@ -26,7 +26,7 @@ case ":$PATH:" in
;;
esac
-if [[ ${EUID} == 0 && -O ${XDG_CONFIG_HOME:-${HOME}} ]]; then
+if [ $(id -u) -eq 0 ] && [ $(stat -c %u -L ${XDG_CONFIG_HOME:-${HOME}}) -eq 0 ]; then
# Running as root with HOME owned by root.
# Pass --user-data-dir to work around upstream failsafe.
CHROMIUM_FLAGS="--user-data-dir=${XDG_CONFIG_HOME:-${HOME}/.config}/chromium
@@ -34,6 +34,6 @@ if [[ ${EUID} == 0 && -O ${XDG_CONFIG_HOME:-${HOME}} ]]; then
fi
# Set the .desktop file name
-export CHROME_DESKTOP="chromium-browser-chromium.desktop"
+export CHROME_DESKTOP="chromium.desktop"
-exec -a "chromium-browser" "$PROGDIR/chrome" --extra-plugin-dir=/usr/lib/nsbrowser/plugins ${CHROMIUM_FLAGS} "$@"
+exec "$PROGDIR/chrome" --extra-plugin-dir=/usr/lib/nsbrowser/plugins ${CHROMIUM_FLAGS} "$@"
diff --git a/testing/chromium/chromium.default b/testing/chromium/chromium.conf
index 28be1f8059..28be1f8059 100644
--- a/testing/chromium/chromium.default
+++ b/testing/chromium/chromium.conf
diff --git a/testing/chromium/google-api.keys b/testing/chromium/google-api.keys
new file mode 100644
index 0000000000..8cd0f0ab09
--- /dev/null
+++ b/testing/chromium/google-api.keys
@@ -0,0 +1,10 @@
+IyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMj
+IyMjIyMKIyBQbGVhc2UgZG9udCB1c2UgdGhlc2Uga2V5cyBvdXRzaWRlIG9mIEFscGluZSBMaW51
+eCBwcm9qZWN0ICMKIyBZb3UgY2FuIGNyZWF0ZSB5b3VyIG93biBhdDogICAgICAgICAgICAgICAg
+ICAgICAgICAgICAgICAgICMKIyBodHRwOi8vd3d3LmNocm9taXVtLm9yZy9kZXZlbG9wZXJzL2hv
+dy10b3MvYXBpLWtleXMgICAgICAgICMKIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMj
+IyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMjIyMKX2dvb2dsZV9hcGlfa2V5PSJBSXphU3lDUkk0
+RUdwRHVfQUFISThFMnllbmpWaFdRZHA0RzhpZ2MiCl9nb29nbGVfZGVmYXVsdF9jbGllbnRfaWQ9
+IjQ5NzU1MDYyMjM2Ny11YnRrbWQzYjJwcDVndWxiYTVuNmhhNnNxNG4zNWVoai5hcHBzLmdvb2ds
+ZXVzZXJjb250ZW50LmNvbSIKX2dvb2dsZV9kZWZhdWx0X2NsaWVudF9zZWNyZXQ9Ik5hQ1g4dElJ
+QXBocmpzNTZuM1RwSHhfZSIKCg==