aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-10-12 09:50:44 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-10-12 09:52:02 +0000
commit9b417b382a20d785fed4a81c4bb3210170d03a26 (patch)
tree97e82303951f45e6e3f3129d782f3181d7a1883c /testing
parent55ff25a8b200a0425a7424b8450ff72498dd259f (diff)
downloadaports-9b417b382a20d785fed4a81c4bb3210170d03a26.tar.bz2
aports-9b417b382a20d785fed4a81c4bb3210170d03a26.tar.xz
testing/gajim: new aport
A full featured and easy to use XMPP client https://gajim.org/
Diffstat (limited to 'testing')
-rw-r--r--testing/gajim/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/gajim/APKBUILD b/testing/gajim/APKBUILD
new file mode 100644
index 0000000000..6e36017b0c
--- /dev/null
+++ b/testing/gajim/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=gajim
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="A full featured and easy to use XMPP client"
+url="https://gajim.org/"
+arch="noarch"
+license="GPL-3.0-only"
+depends="py3-cairo py3-gobject3 py3-asn1 py3-nbxmpp py3-openssl gtk+3.0"
+makedepends="py-setuptools python3-dev gettext-dev"
+checkdepends="xvfb dbus"
+source="https://$pkgname.org/downloads/1.0/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ local xvfb_pid
+ cd "$builddir"
+ Xvfb :4242 &
+ xvfb_pid=$!
+ if env DISPLAY=:4242 python3 setup.py test; then
+ kill $xvfb_pid
+ return 0
+ else
+ kill $xvfb_pid
+ return 1
+ fi
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a6d7f92a22a9dddc8a4b07eda0aae0b6fb4db57c73133ee19937f7e2a2a82c5351051d1f3627c94a44434276ed001b83d375f708f177962125af66cda8579ec8 gajim-1.0.3.tar.bz2"
+