aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-23 20:22:31 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-07-26 15:06:26 +0300
commitb1973034f77d25256459bfb0707bf1bdaf19e39f (patch)
tree2d11c9521944ec8630197d8444906283532d5333 /testing
parent2a12ddbc0d5281856513cf68ca3d942c7a02686b (diff)
downloadaports-b1973034f77d25256459bfb0707bf1bdaf19e39f.tar.bz2
aports-b1973034f77d25256459bfb0707bf1bdaf19e39f.tar.xz
testing/libtorrent-rasterbar: enable tests, add check function
Diffstat (limited to 'testing')
-rw-r--r--testing/libtorrent-rasterbar/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/testing/libtorrent-rasterbar/APKBUILD b/testing/libtorrent-rasterbar/APKBUILD
index 8b39ed38aa..bd73e14fb3 100644
--- a/testing/libtorrent-rasterbar/APKBUILD
+++ b/testing/libtorrent-rasterbar/APKBUILD
@@ -23,10 +23,17 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ --enable-tests \
--enable-python-binding \
--with-boost-system=boost_system
make
}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install