aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-07-25 19:14:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-26 15:46:55 +0000
commite76a44c248d87daa3b03e04735e14075521bb1f9 (patch)
tree75bff161bda4cb1d998fc53f5ba06c4dd2f74a75 /testing
parent0d303225f8df757f2efa8343d64189a5b1060856 (diff)
downloadaports-e76a44c248d87daa3b03e04735e14075521bb1f9.tar.bz2
aports-e76a44c248d87daa3b03e04735e14075521bb1f9.tar.xz
testing/openmpi: fix build hang on ppc64le by disabling builtit atomics
Diffstat (limited to 'testing')
-rw-r--r--testing/openmpi/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/testing/openmpi/APKBUILD b/testing/openmpi/APKBUILD
index 1a725e507f..941b00395d 100644
--- a/testing/openmpi/APKBUILD
+++ b/testing/openmpi/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=openmpi
pkgver=3.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Message passing library for high-performance computing"
url="https://www.open-mpi.org/"
# disable ppc64le until opal_fifo test can be fixed
-arch="all !ppc64le"
+arch="all"
license="BSD"
makedepends="perl gfortran hwloc-dev libevent-dev libgomp"
subpackages="$pkgname-dev:_dev $pkgname-doc"
@@ -14,13 +14,20 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+
+ local disable_atomics=""
+ case "$CARCH" in
+ ppc64le) disable_atomics="--disable-builtin-atomics";;
+ esac
+
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
--sysconfdir=/etc/$pkgname \
--enable-ipv6 \
--with-threads=posix \
- --with-hwloc=/usr
+ --with-hwloc=/usr \
+ $disable_atomics
make
}