aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-10-11 11:31:54 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-12 19:24:01 +0000
commite95f831e72753f241127d430478b4c819414ed5e (patch)
treeef8c748aeae2de4aad030a45b1f603c663147ec3 /testing
parent7b958a9fb9900c1447c577cc16a838177b2ad647 (diff)
downloadaports-e95f831e72753f241127d430478b4c819414ed5e.tar.bz2
aports-e95f831e72753f241127d430478b4c819414ed5e.tar.xz
testing/ibus-anthy: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/ibus-anthy/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/ibus-anthy/APKBUILD b/testing/ibus-anthy/APKBUILD
new file mode 100644
index 0000000000..a08730fee1
--- /dev/null
+++ b/testing/ibus-anthy/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=ibus-anthy
+pkgver=1.5.10
+pkgrel=0
+pkgdesc="Japanese input method Anthy IMEngine for IBus Framework"
+url="http://ibus.googlecode.com/"
+arch="all"
+license="GPL-2.0"
+depends="ibus anthy py-gobject3 gtk-update-icon-cache"
+makedepends="
+ m4 automake autoconf intltool gobject-introspection
+ gobject-introspection-dev ibus-dev anthy-dev
+ py3-pytest
+"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ibus/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+subpackages="$pkgname-lang"
+# anthy tests require a running X server
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./autogen.sh \
+ --prefix=/usr \
+ --libexec=/usr/lib/ibus
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="37a9b86ebe32ea639637880fffb29a86b971534e2faa668b2f88df66568bc99c58685481e1f7ae1f05fcf85d1816e3ef3e5fbc065207ac4188e0edcae8eb4925 ibus-anthy-1.5.10.tar.gz"