aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-06-06 07:14:02 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-06-06 07:14:12 +0000
commitf819fff293e3ffcfda1dd2b2c688873953007af0 (patch)
tree2d1acbfddac276154b0025f94102b4799c4ad011 /testing
parent3a5f6e270b115c85a631cfcf3e2110fe3963fd3d (diff)
downloadaports-f819fff293e3ffcfda1dd2b2c688873953007af0.tar.bz2
aports-f819fff293e3ffcfda1dd2b2c688873953007af0.tar.xz
testing/py-tappy: new aport
Set of tools for working with the Test Anything Protocol (TAP)
Diffstat (limited to 'testing')
-rw-r--r--testing/py-tappy/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py-tappy/APKBUILD b/testing/py-tappy/APKBUILD
new file mode 100644
index 0000000000..2acecc4a4a
--- /dev/null
+++ b/testing/py-tappy/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py-tappy
+_pkgname=tap.py
+pkgver=2.4
+pkgrel=0
+pkgdesc="Python Test Anything Protocol (TAP) tools"
+url="https://github.com/python-tap/tappy"
+arch="noarch"
+license="BSD-2-Clause"
+makedepends="python2-dev python3-dev py-setuptools py-babel"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/tap.py/tap.py-${pkgver}.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir/tappy-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+
+
+sha512sums="3c3bd11033877c1c8ebfc0a35fc27e8e063b564c4dcc2fa9fde501d820f960010501574860888c37b630977239abf61a6d000f46244f055238dc5222b3184ef2 py-tappy-2.4.tar.gz"