aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2018-05-25 12:36:14 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-05-29 23:50:19 +0300
commitfc673f317235201074ed89ccc0e9b078ba8c1d4c (patch)
tree02651c62f31a523f8390a698be0778a81213885d /testing
parentdd36ce32c7ebdf653ef34e321c7c3d82b2881be0 (diff)
downloadaports-fc673f317235201074ed89ccc0e9b078ba8c1d4c.tar.bz2
aports-fc673f317235201074ed89ccc0e9b078ba8c1d4c.tar.xz
testing/php7-phalcon: new aport
High performance, full-stack PHP framework delivered as a C extension https://github.com/phalcon/cphalcon https://phalconphp.com
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-phalcon/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/php7-phalcon/APKBUILD b/testing/php7-phalcon/APKBUILD
new file mode 100644
index 0000000000..85009593ad
--- /dev/null
+++ b/testing/php7-phalcon/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=php7-phalcon
+_pkgext=phalcon
+_pkgreal=cphalcon
+pkgver=3.3.2
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="High performance, full-stack PHP framework delivered as a C extension"
+url="https://github.com/phalcon/cphalcon"
+arch="all"
+options="!check" # It needs some external services to run checks
+license="BSD-3-Clause"
+depends="php7-curl php7-fileinfo php7-gettext php7-json php7-mbstring php7-openssl php7-pdo"
+makedepends="php7-dev autoconf pcre-dev gd-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/phalcon/$_pkgreal/archive/v$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$_pkgver/build/${pkgname%%-*}/safe"
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=/usr/bin/php-config7
+ make
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir/" install
+ rm -fr "$pkgdir/usr/include"
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgext.so" > "$pkgdir"/etc/php7/conf.d/$_pkgext.ini
+}
+
+sha512sums="401be2344312a247a802008fddca9fd4c58b67fb5e726765f063bc00fa1279767e86782e3d055194db5b5a3efa828399e0da7e19f204e6b1e2be00bed4eb8fb5 php7-phalcon-3.3.2.tar.gz"