aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/chmlib
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/chmlib
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/chmlib')
-rw-r--r--unmaintained/chmlib/APKBUILD58
-rw-r--r--unmaintained/chmlib/headers.patch18
-rw-r--r--unmaintained/chmlib/stdtypes.patch20
3 files changed, 96 insertions, 0 deletions
diff --git a/unmaintained/chmlib/APKBUILD b/unmaintained/chmlib/APKBUILD
new file mode 100644
index 0000000000..334ddcab80
--- /dev/null
+++ b/unmaintained/chmlib/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=chmlib
+pkgver=0.40
+pkgrel=2
+pkgdesc="Library for dealing with Microsoft ITSS/CHM format files"
+url="http://morte.jedrea.com/~jedwin/projects/chmlib/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://morte.jedrea.com/~jedwin/projects/${pkgname}/${pkgname}-${pkgver}.tar.bz2
+ headers.patch
+ stdtypes.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+
+ local i
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7ea49ed8c335215c1edc6fae83e6b912 chmlib-0.40.tar.bz2
+668afec836d2af8e50e6f8a953744539 headers.patch
+d8c82136eb221506f42b48d219cc3f5d stdtypes.patch"
+sha256sums="3449d64b0cf71578b2c7e3ddc048d4af3661f44a83941ea074a7813f3a59ffa3 chmlib-0.40.tar.bz2
+60b67803466def393789c10daef789e0a54176aa1493d2e1e285730c60185683 headers.patch
+1d1124f81c955dcf856013d37095c212a8ad858a1dce52bd07fecc736a0eb82e stdtypes.patch"
+sha512sums="3a3e151cf455b19e9e7c163a1d1e5ac52e8196f0b98f77932c72af58f3517824b9244667a18279ae754ccea784f6d6ab0c47465e74e3768ce98bb7dca0ca16e3 chmlib-0.40.tar.bz2
+940d6b766ada58cbdad31a4748de1f5bcad83170d2b233397dee80f4bd92e13c0f3fa2a027b5834c8547018f67e12726cbd6a8de7540ca9b3d12fda45db02d1d headers.patch
+afd879f78d4d532be3f3253a645b54588b0faff7445bc856b461ceba4ad0fb8d4d1fd9d1497675894cfb40c2174e21a8a2842a35e66deb6ab8adab6cbb996319 stdtypes.patch"
diff --git a/unmaintained/chmlib/headers.patch b/unmaintained/chmlib/headers.patch
new file mode 100644
index 0000000000..d60af28639
--- /dev/null
+++ b/unmaintained/chmlib/headers.patch
@@ -0,0 +1,18 @@
+--- src/chm_http.c
++++ src/chm_http.c
+@@ -34,6 +34,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #if __sun || __sgi
+ #include <strings.h>
+ #endif
+@@ -42,6 +43,7 @@
+ #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+
+ /* threading includes */
+ #include <pthread.h>
diff --git a/unmaintained/chmlib/stdtypes.patch b/unmaintained/chmlib/stdtypes.patch
new file mode 100644
index 0000000000..0f92320176
--- /dev/null
+++ b/unmaintained/chmlib/stdtypes.patch
@@ -0,0 +1,20 @@
+--- src/chm_lib.c
++++ src/chm_lib.c
+@@ -149,6 +149,17 @@ typedef unsigned __int32 UInt32;
+ typedef __int64 Int64;
+ typedef unsigned __int64 UInt64;
+
++/* Linux: use C standard types */
++#elif defined(__linux__)
++#include <stdint.h>
++typedef unsigned char UChar;
++typedef int16_t Int16;
++typedef uint16_t UInt16;
++typedef int32_t Int32;
++typedef uint32_t UInt32;
++typedef int64_t Int64;
++typedef uint64_t UInt64;
++
+ /* I386, 32-bit, non-Windows */
+ /* Sparc */
+ /* MIPS */