aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/crconf
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/crconf
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/crconf')
-rw-r--r--unmaintained/crconf/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/crconf/APKBUILD b/unmaintained/crconf/APKBUILD
new file mode 100644
index 0000000000..07c25a37fd
--- /dev/null
+++ b/unmaintained/crconf/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=crconf
+pkgver=0_pre2
+_ver=${pkgver/0_/}
+pkgrel=0
+pkgdesc="Linux crypto layer configuration tool"
+url="http://sourceforge.net/projects/crconf/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/project/crconf/crconf-$_ver.tar.gz
+"
+
+_builddir="$srcdir"/crconf-$_ver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" SBINDIR="/usr/sbin"
+}
+
+md5sums="4b96e3fbd570d694ea25659a79a6db5c crconf-pre2.tar.gz"
+sha256sums="15d39b599acda93a50f473190e702d593ba13613b6ed31711f3584b5726b81b8 crconf-pre2.tar.gz"
+sha512sums="e4526626c71391968beafaf606bc477849ed11007bcfe4dd9b056bdbd08d19dce41b18418693fd5d2fab29f618e3fdad3ec4f4f2ea269207443e94e7552b4daa crconf-pre2.tar.gz"