aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/dconf-editor
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/dconf-editor
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/dconf-editor')
-rw-r--r--unmaintained/dconf-editor/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/unmaintained/dconf-editor/APKBUILD b/unmaintained/dconf-editor/APKBUILD
new file mode 100644
index 0000000000..fb03be67df
--- /dev/null
+++ b/unmaintained/dconf-editor/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dconf-editor
+pkgver=3.16.0
+pkgrel=0
+pkgdesc="Configuration editor for dconf"
+url="https://wiki.gnome.org/Projects/dconf"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev vala gtk+3.0-dev dconf-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/dconf-editor/3.16/dconf-editor-$pkgver.tar.xz"
+
+_builddir="$srcdir"/dconf-editor-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fd0b398d21274b5412c0f0bd3643fab6 dconf-editor-3.16.0.tar.xz"
+sha256sums="811af889202996495f6074a5dcf6df84c0300eaa7fc79cda31682815b8d162f9 dconf-editor-3.16.0.tar.xz"
+sha512sums="4df64f915c6b1b0c578db826e5eff5c651f2f5f3bffc7b60e289bb5a46c1e39f9a9f0fd59a7dc2f50e6a7794b010ebfa549b8debc612de893f242c2d896f22c5 dconf-editor-3.16.0.tar.xz"