aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ejdb/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ejdb/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ejdb/APKBUILD')
-rw-r--r--unmaintained/ejdb/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/ejdb/APKBUILD b/unmaintained/ejdb/APKBUILD
new file mode 100644
index 0000000000..4adc7b58f7
--- /dev/null
+++ b/unmaintained/ejdb/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=ejdb
+pkgver=1.2.10
+pkgrel=0
+pkgdesc="Embedded JSON Database engine"
+url="http://ejdb.org/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="cmake $depends_dev zlib-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="ejdb-$pkgver.tar.gz::https://github.com/Softmotions/ejdb/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/ejdb-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ mkdir build && cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SAMPLES=OFF \
+ -DPACKAGE_TGZ=OFF \
+ ../ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="85a825c1c880a51a869fadba11a7e52a ejdb-1.2.10.tar.gz"
+sha256sums="3a6d4a487e02c05dd67e72a77ee6082fbb1f5a19d4f7f15d14e1c891bbfe520e ejdb-1.2.10.tar.gz"
+sha512sums="84c864ec89714eed32256d7301f0ec525c59595f5ae1f41e3bb05b5fb143286308cc6a26de955603f990b1a46aaae2a5fa54c4c42baef91fab75494d0dd3b83e ejdb-1.2.10.tar.gz"