aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/kyototycoon
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/kyototycoon
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/kyototycoon')
-rw-r--r--unmaintained/kyototycoon/APKBUILD58
-rw-r--r--unmaintained/kyototycoon/musl-header-fix.patch11
2 files changed, 69 insertions, 0 deletions
diff --git a/unmaintained/kyototycoon/APKBUILD b/unmaintained/kyototycoon/APKBUILD
new file mode 100644
index 0000000000..e67b555f65
--- /dev/null
+++ b/unmaintained/kyototycoon/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=kyototycoon
+pkgver=0.9.56
+pkgrel=0
+pkgdesc="a leightweight cache/storage server"
+url="http://fallabs.com/kyototycoon/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev lua5.1-dev zlib-dev kyotocabinet-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://fallabs.com/kyototycoon/pkg/kyototycoon-$pkgver.tar.gz
+ musl-header-fix.patch
+ "
+
+_builddir="$srcdir"/kyototycoon-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/kyototycoon \
+ --disable-static \
+ --enable-lua \
+ --with-lua=/usr/lua5.1 \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2e95a4681f6d05f9e363985fbb933948 kyototycoon-0.9.56.tar.gz
+765f21d0bdad8b07c283330bc460693d musl-header-fix.patch"
+sha256sums="553e4ea83237d9153cc5e17881092cefe0b224687f7ebcc406b061b2f31c75c6 kyototycoon-0.9.56.tar.gz
+78b17a2fad4f065bbf7d8b3e1636ab5fed0ca30990b2ebd9393c60d77f2b13e9 musl-header-fix.patch"
+sha512sums="7722297287194d67dfaae9e7595439274d7639d139a954eb8dee4a5e6d019e8a1da3773b538e80244eb97b867f0b6d0db592fa66fdbb2bd8d9358a6acd82cd4c kyototycoon-0.9.56.tar.gz
+2953c5f3b9cc4ef54d14fa9481b9c4085fd1bb200d03c60582ec947329ecb0da696c164d74e88aa1a766b9475f0ab3c98b17ab18998286de6f3730513255ed0a musl-header-fix.patch"
diff --git a/unmaintained/kyototycoon/musl-header-fix.patch b/unmaintained/kyototycoon/musl-header-fix.patch
new file mode 100644
index 0000000000..75edaef889
--- /dev/null
+++ b/unmaintained/kyototycoon/musl-header-fix.patch
@@ -0,0 +1,11 @@
+--- ./ktdbext.h.orig
++++ ./ktdbext.h
+@@ -16,6 +16,8 @@
+ #ifndef _KTDBEXT_H // duplication check
+ #define _KTDBEXT_H
+
++#include <unistd.h>
++
+ #include <ktcommon.h>
+ #include <ktutil.h>
+ #include <ktulog.h>