aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/packagekit
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/packagekit
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/packagekit')
-rw-r--r--unmaintained/packagekit/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/packagekit/APKBUILD b/unmaintained/packagekit/APKBUILD
new file mode 100644
index 0000000000..52eb8d9719
--- /dev/null
+++ b/unmaintained/packagekit/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=packagekit
+pkgver=0.8.3
+pkgrel=0
+pkgdesc="Package management service"
+url="http://www.packagekit.org"
+arch="all"
+license="GPLv2+ and LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="dbus-glib-dev polkit-dev bash intltool sqlite-dev gtk+-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://www.packagekit.org/releases/PackageKit-$pkgver.tar.xz"
+
+_builddir="$srcdir"/PackageKit-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-qt \
+ --disable-systemd \
+ --enable-gtk-module \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="53210d9a54d3c9044e4c6edc16c99bd4 PackageKit-0.8.3.tar.xz"