aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/winetricks
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/winetricks
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/winetricks')
-rw-r--r--unmaintained/winetricks/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/winetricks/APKBUILD b/unmaintained/winetricks/APKBUILD
new file mode 100644
index 0000000000..702c204900
--- /dev/null
+++ b/unmaintained/winetricks/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor:
+# Maintainer:
+pkgname=winetricks
+pkgver=20111115
+pkgrel=0
+pkgdesc="manage virtual windows environments using wine"
+url="http://winetricks.org"
+arch="noarch"
+license="LGPL"
+depends="grep cabextract zenity p7zip"
+makedepends=""
+install=""
+subpackages=""
+source="http://winetricks.org/download/releases/winetricks-$pkgver.tgz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+unpack() {
+ # manually unpack, as the tgz does not any paths at all
+ mkdir -p "$_builddir"
+ cd "$_builddir"
+ tar xzvf ../winetricks-$pkgver.tgz
+}
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin
+ install -Dm755 winetricks "$pkgdir"/usr/bin
+}
+
+md5sums="79141446df0f98115108e96820bb9c3e winetricks-20111115.tgz"