aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-08-28 22:23:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-28 22:24:21 +0000
commit32f78b1f669188be2ab8efbb234b3040bb737e5e (patch)
treec61a351e1e9ed3c4d350c42a478e208d7ea7c45a /unmaintained
parent047b36f3d100572bf258f541accc2e1ec90c86b7 (diff)
downloadaports-32f78b1f669188be2ab8efbb234b3040bb737e5e.tar.bz2
aports-32f78b1f669188be2ab8efbb234b3040bb737e5e.tar.xz
unmaintained/beecrypt: move from main
It does not look like anything uses beecrypt and the testcase fails. The problem have been reported upstream https://sourceforge.net/p/beecrypt/support-requests/19/ Meanwhile we move it to unmaintained.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/beecrypt/APKBUILD45
-rw-r--r--unmaintained/beecrypt/beecrypt-4.1.2-base64.patch11
2 files changed, 56 insertions, 0 deletions
diff --git a/unmaintained/beecrypt/APKBUILD b/unmaintained/beecrypt/APKBUILD
new file mode 100644
index 0000000000..a1a2aa8435
--- /dev/null
+++ b/unmaintained/beecrypt/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=beecrypt
+pkgver=4.2.1
+pkgrel=2
+pkgdesc="A general-purpose cryptography library"
+url="http://sourceforge.net/projects/beecrypt"
+arch="all"
+license="LGPL2+"
+makedepends="libtool m4"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ LIBS=-lgomp ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-threads \
+ --enable-shared \
+ --without-java \
+ --without-python \
+ --with-cplusplus=no
+ make libaltdir=/usr/lib
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make libaltdir=/usr/lib DESTDIR="$pkgdir" install
+}
+
+sha512sums="59995d53c024efe6344a21ac0d6d55fbe652488a4a22cc6719f9fc3851d56697fa8738937d48aa1e6f9ebe749de61ac3c79a5f0cea793872213c3bdf922e71bc beecrypt-4.2.1.tar.gz"
diff --git a/unmaintained/beecrypt/beecrypt-4.1.2-base64.patch b/unmaintained/beecrypt/beecrypt-4.1.2-base64.patch
new file mode 100644
index 0000000000..c6c370bd07
--- /dev/null
+++ b/unmaintained/beecrypt/beecrypt-4.1.2-base64.patch
@@ -0,0 +1,11 @@
+Fix b64encode() for data starting with NUL from Miloslav Trmac <mitr@redhat.com>
+--- beecrypt-4.1.2/base64.c.b64 2005-04-26 21:46:27.000000000 +0200
++++ beecrypt-4.1.2/base64.c 2005-04-26 21:47:48.000000000 +0200
+@@ -253,7 +253,6 @@
+ unsigned c;
+
+ if (s == NULL) return NULL;
+- if (*s == '\0') return calloc(1, sizeof(*t));
+
+ if (ns == 0) ns = strlen((const char*) s);
+ nt = ((ns + 2) / 3) * 4;