aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-16 12:07:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-16 12:07:13 +0000
commit7dc24d7ca27a3c232af70d5035ab23355e90e7c2 (patch)
treebe9e7673eca8111e4e422045c44beca73a4d3db6 /unmaintained
parent770b162597fa80a9dc0e861cff93d8c885935bf2 (diff)
downloadaports-7dc24d7ca27a3c232af70d5035ab23355e90e7c2.tar.bz2
aports-7dc24d7ca27a3c232af70d5035ab23355e90e7c2.tar.xz
unmaintained/rawtherapee: does not build
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/rawtherapee/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/rawtherapee/APKBUILD b/unmaintained/rawtherapee/APKBUILD
new file mode 100644
index 0000000000..1bcc428463
--- /dev/null
+++ b/unmaintained/rawtherapee/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=rawtherapee
+pkgver=4.2
+pkgrel=1
+pkgdesc="RawTherapee is image processing software simular to Lightroom or Aperture"
+url="http://rawtherapee.com"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="bzip2-dev exiv2-dev expat-dev fftw-dev glib-dev gtk+2.0-dev \
+ gtk-engines-dev gtkmm-dev lcms2-dev libcanberra-dev \
+ libpng-dev libsigc++-dev tiff-dev zlib-dev cmake mercurial \
+ libiptcdata-dev libjpeg-turbo-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://rawtherapee.com/shared/source/${pkgname}-${pkgver}.tar.xz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="e6510ed56fdc35aa712b4c0f54c52ac0 rawtherapee-4.2.tar.xz"
+sha256sums="fa4c13e8842df096b19d2dabaed5a61f5f9d4547f7b4f0dc6b77f80bdec16479 rawtherapee-4.2.tar.xz"
+sha512sums="feec61aeb84804cf01ff03fa9d7309f0eb3c04c43818c8397cc6f3ee762aca19484bce7594414d2141248b9740bdd4269fd86f76dcf391c61d4647fa169d48f6 rawtherapee-4.2.tar.xz"