aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-04-09 06:25:47 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-09 06:25:47 +0000
commit8b0d7dd4e894d2fafd4ff8bf46cadf7e40134717 (patch)
tree80b3ddfe87daa367a50ea2a32149114d332e7897 /unmaintained
parent91b32f90c7a33986207643a7a3a7426a0f9186e6 (diff)
downloadaports-8b0d7dd4e894d2fafd4ff8bf46cadf7e40134717.tar.bz2
aports-8b0d7dd4e894d2fafd4ff8bf46cadf7e40134717.tar.xz
unmaintained/alpine: upstream deleted distribution
We may move this back to community once a proper fork is selected.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/alpine/APKBUILD55
-rw-r--r--unmaintained/alpine/uclibc-musl.patch20
2 files changed, 75 insertions, 0 deletions
diff --git a/unmaintained/alpine/APKBUILD b/unmaintained/alpine/APKBUILD
new file mode 100644
index 0000000000..b38ae908e9
--- /dev/null
+++ b/unmaintained/alpine/APKBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=alpine
+pkgver=2.21
+_ver=${pkgver%_p*}
+_pver=${pkgver##*_p}
+pkgrel=2
+pkgdesc="Text-based email client, friendly for novices but powerful"
+url="http://www.washington.edu/alpine/"
+arch="all"
+license="Apache-2.0"
+depends=""
+makedepends="openldap-dev heimdal-dev ncurses-dev libressl-dev
+ automake autoconf libtool"
+subpackages="$pkgname-doc"
+source="http://alpine.freeiz.com/alpine/release/src/alpine-$pkgver.tar.xz
+ uclibc-musl.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$_ver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+ libtoolize --force && aclocal -I m4 && autoconf \
+ && automake --force --add-missing || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-passfile=.pine-pass \
+ --without-tcl \
+ --disable-shared \
+ --with-system-pinerc=/etc/alpine.d/pine.conf \
+ --with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="a2a36a033c8af79810816a7da7185c269808ba6d84d013691fd8b3764c63f5fb2284e6844ec5a5e99d168514ae636debf59fae962533a2916679e4e9109c6264 alpine-2.21.tar.xz
+1b14352571dd12749bbb6ebc1fd468dbb5a8e4d7a27e87f5baeb00a60d5c1a016d925c6bc776da7e1dbf0ad8d799a65049b64774113274d7ffb07c7b1b196775 uclibc-musl.patch"
diff --git a/unmaintained/alpine/uclibc-musl.patch b/unmaintained/alpine/uclibc-musl.patch
new file mode 100644
index 0000000000..9ebe5de183
--- /dev/null
+++ b/unmaintained/alpine/uclibc-musl.patch
@@ -0,0 +1,20 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -723,7 +723,7 @@
+ else
+ dnl preload c-client default locations/options
+ case $host in
+- *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*)
++ *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*|*-linux-uclibc|*-linux-musl*)
+ if test -f /etc/fedora-release -o -f /etc/redhat-release -o -f /etc/redhat_version ; then
+ alpine_SSLTYPE="nopwd"
+ if test -d /etc/pki/tls ; then
+@@ -1059,7 +1059,7 @@
+ dnl build from c-client. Most of this will go away when c-client
+ dnl adopts configure
+ case "$host" in
+- *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*)
++ *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*|*-linux-uclibc|*-linux-musl*)
+ alpine_path_delim="/"
+ alpine_mode_readonly="(0600)"
+ if test -f /etc/fedora-release ; then