aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-14 01:44:01 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-14 01:44:01 +0100
commit91f0ecf3e4d468bf71dcf7af3c06be453f0364e3 (patch)
treed00fd8b200cac0aa1ed169e7a85a37192fec5f9b /unmaintained
parentf10ea8df610c3be33ff846a4e92ab4e846f79d05 (diff)
downloadaports-91f0ecf3e4d468bf71dcf7af3c06be453f0364e3.tar.bz2
aports-91f0ecf3e4d468bf71dcf7af3c06be453f0364e3.tar.xz
unmaintained/oprofile: move from main
This aport is disabled for years.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/oprofile/APKBUILD55
-rw-r--r--unmaintained/oprofile/op-AT_BASE_PLATFORM.patch45
2 files changed, 100 insertions, 0 deletions
diff --git a/unmaintained/oprofile/APKBUILD b/unmaintained/oprofile/APKBUILD
new file mode 100644
index 0000000000..cc7ae974fc
--- /dev/null
+++ b/unmaintained/oprofile/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=oprofile
+pkgver=0.9.9
+pkgrel=0
+pkgdesc="A System Profiler for Linux"
+url="http://oprofile.sourceforge.net/"
+arch=""
+license="GPL"
+depends=""
+makedepends="popt-dev gettext-dev"
+install=
+subpackages="$pkgname-doc"
+options="libtool"
+source="http://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ op-AT_BASE_PLATFORM.patch"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-pic \
+ || return 1
+ make -j1 || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+md5sums="00aec1287da2dfffda17a9b1c0a01868 oprofile-0.9.9.tar.gz
+fc86dc788151ff8d0348a0c2fd9bddb4 op-AT_BASE_PLATFORM.patch"
+sha256sums="1e523400daaba7b8d0d15269e977a08b40edfea53970774b69ae130e25117597 oprofile-0.9.9.tar.gz
+f96d25ee22040085ad5b5026ff5116f83154fed345ce07c5293012112fbd5ec0 op-AT_BASE_PLATFORM.patch"
+sha512sums="98cc3d2c15744d02ed649833cf4797482aec73bd52653e916f80b490e17a8250d988c4c945e52dd8999a0d0603fec405e99c9570dfc54baa4992950fe4d8763f oprofile-0.9.9.tar.gz
+3f9ef8330cfea7f0f3f4d0cf824398ef42eee187e50a6d9458307954d2cebbe60573c7879d63fa6a6b9d6c76152f7fc95ba5b1bcac1a21a5ce07f2af1c861b6f op-AT_BASE_PLATFORM.patch"
diff --git a/unmaintained/oprofile/op-AT_BASE_PLATFORM.patch b/unmaintained/oprofile/op-AT_BASE_PLATFORM.patch
new file mode 100644
index 0000000000..ea77357b69
--- /dev/null
+++ b/unmaintained/oprofile/op-AT_BASE_PLATFORM.patch
@@ -0,0 +1,45 @@
+http://sourceforge.net/p/oprofile/bugs/245/
+
+Index: oprof-work/libop/op_cpu_type.c
+===================================================================
+--- oprof-work.orig/libop/op_cpu_type.c
++++ oprof-work/libop/op_cpu_type.c
+@@ -23,9 +23,16 @@
+ #include <elf.h>
+ #include <link.h>
+
++#include "config.h"
+ #include "op_cpu_type.h"
+ #include "op_hw_specific.h"
+
++/* A macro to be used for ppc64 architecture-specific code. The '__powerpc__' macro
++ * is defined for both ppc64 and ppc32 architectures, so we must further qualify by
++ * including the 'HAVE_LIBPFM' macro, since that macro will be defined only for ppc64.
++ */
++#define PPC64_ARCH (HAVE_LIBPFM) && ((defined(__powerpc__) || defined(__powerpc64__)))
++
+ struct cpu_descr {
+ char const * pretty;
+ char const * name;
+@@ -176,6 +183,7 @@ static char * _get_cpuinfo_cpu_type(char
+ return _get_cpuinfo_cpu_type_line(buf, len, prefix, 1);
+ }
+
++#if PPC64_ARCH
+ // The aux vector stuff below is currently only used by ppc64 arch
+ static ElfW(auxv_t) * auxv_buf = NULL;
+
+@@ -312,6 +320,13 @@ static op_cpu _get_ppc64_cpu_type(void)
+ cpu_type = op_get_cpu_number(cpu_type_str);
+ return cpu_type;
+ }
++#else
++static op_cpu _get_ppc64_cpu_type(void)
++{
++ return CPU_NO_GOOD;
++}
++#endif
++
+
+ static op_cpu _get_arm_cpu_type(void)
+ {