aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorArch3y <arch3y@arch3y.com>2017-04-24 21:55:00 -0400
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 07:25:05 +0000
commitce9cd352283a024dabbc671fb5028757575e831b (patch)
tree754e91affcb99c4a888a03f7a3820874f1a179b1 /unmaintained
parent87d740c28ee69228e75d0f2f4963e7bf92467f26 (diff)
downloadaports-ce9cd352283a024dabbc671fb5028757575e831b.tar.bz2
aports-ce9cd352283a024dabbc671fb5028757575e831b.tar.xz
testing/httrack: new aport
Website Copier - Free Software Offline Browser http://www.httrack.com/ [TT: modernize]
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/httrack/APKBUILD55
-rw-r--r--unmaintained/httrack/compile_fix.patch22
2 files changed, 0 insertions, 77 deletions
diff --git a/unmaintained/httrack/APKBUILD b/unmaintained/httrack/APKBUILD
deleted file mode 100644
index c9c3d7fd9a..0000000000
--- a/unmaintained/httrack/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: <xmingske@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=httrack
-pkgver=3.48.19
-pkgrel=0
-pkgdesc="Website Copier - Free Software Offline Browser"
-url="http://www.httrack.com/"
-arch="all"
-license="GPL3"
-depends=""
-makedepends="zlib-dev openssl-dev"
-source="http://mirror.httrack.com/${pkgname}-${pkgver}.tar.gz
- compile_fix.patch
- "
-subpackages="$pkgname-doc"
-
-_builddir="${srcdir}"/${pkgname}-${pkgver}
-
-prepare() {
- local pf
- cd "${_builddir}"
- for pf in $source; do
- case $pf in
- *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
- esac
- done
-}
-
-build() {
- cd "${_builddir}"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --disable-static \
- --disable-dependency-tracking \
- --localstatedir=/var/lib \
- --docdir=/usr/share/doc/httrack \
- || return 1
- make || return 1
-}
-
-package() {
- cd "${_builddir}"
- make DESTDIR="${pkgdir}" install || return 1
-}
-
-md5sums="db07a1a3e41eff1123606c444f8f267d httrack-3.48.19.tar.gz
-df5a7d5cc9be56a08a6c362152256f2b compile_fix.patch"
-sha256sums="16f0cd0ea21042106879238fe4892b56018e106347d69dcb0b93816ee8f68afe httrack-3.48.19.tar.gz
-4bd329ae0c07bcc7905fd56c9da9b04876130e5d521a64ad43c961f87944aab6 compile_fix.patch"
-sha512sums="c7202c4d86963fe935ce1f1a81f43f47544e03e4743528f52acd541ba87d6ef47d9e691b432f9bebedbf06e764bd67fe85748762b6ec3c09491b7528957cda8b httrack-3.48.19.tar.gz
-41534bac32d0f3b94a862d1fe94726dc41407b8fccdf42d8755522b47c8975860f25e5c0c6150900faee3c9b7f1b19fdaa2167c9f4f2f7d63a1a62df29ce36ed compile_fix.patch"
diff --git a/unmaintained/httrack/compile_fix.patch b/unmaintained/httrack/compile_fix.patch
deleted file mode 100644
index ad7aebce11..0000000000
--- a/unmaintained/httrack/compile_fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/httrack.c
-+++ b/src/httrack.c
-@@ -69,7 +69,8 @@
- #include <unistd.h>
- #endif
- #include <ctype.h>
--#ifdef __linux
-+//#ifdef __linux
-+#ifdef __GLIBC__
- #include <execinfo.h>
- #endif
- /* END specific definitions */
-@@ -878,7 +879,8 @@
- #define FD_ERR 2
-
- static void print_backtrace(void) {
--#ifdef __linux
-+//#ifdef __linux
-+#ifdef __GLIBC__
- void *stack[256];
- const int size = backtrace(stack, sizeof(stack)/sizeof(stack[0]));
- if (size != 0) {