aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/xf86-input-libinput/0001-Fix-left-handed-property-not-set-on-all-pointers.patch34
-rw-r--r--main/xf86-input-libinput/APKBUILD12
2 files changed, 5 insertions, 41 deletions
diff --git a/main/xf86-input-libinput/0001-Fix-left-handed-property-not-set-on-all-pointers.patch b/main/xf86-input-libinput/0001-Fix-left-handed-property-not-set-on-all-pointers.patch
deleted file mode 100644
index ba01127d05..0000000000
--- a/main/xf86-input-libinput/0001-Fix-left-handed-property-not-set-on-all-pointers.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 0db82219bb2ad10dcdf3ea8fe8e226858190c83b Mon Sep 17 00:00:00 2001
-From: Evangelos Foutras <evangelos@foutrelis.com>
-Date: Thu, 22 Mar 2018 01:47:07 +0200
-Subject: [PATCH] Fix "left handed" property not set on all pointers
-
-Remove conditional that prevents the LIBINPUT_PROP_LEFT_HANDED{,DEFAULT}
-properties from being set on all pointer devices (only the first got it).
-This appears to be a debugging left-over accidentally merged in
-6d3bd4544a6a2f194fa.
-
-https://bugs.freedesktop.org/show_bug.cgi?id=105667
-
-Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
----
- src/xf86libinput.c | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/src/xf86libinput.c b/src/xf86libinput.c
-index 83ab75d..f9ed8ba 100644
---- a/src/xf86libinput.c
-+++ b/src/xf86libinput.c
-@@ -4930,9 +4930,6 @@ LibinputInitLeftHandedProperty(DeviceIntPtr dev,
- if (!subdevice_has_capabilities(dev, CAP_POINTER|CAP_TABLET))
- return;
-
-- if (prop_left_handed != 0)
-- return;
--
- if (!libinput_device_config_left_handed_is_available(device) ||
- driver_data->capabilities & CAP_TABLET)
- return;
---
-2.16.2
-
diff --git a/main/xf86-input-libinput/APKBUILD b/main/xf86-input-libinput/APKBUILD
index 7c550a355f..315e67d912 100644
--- a/main/xf86-input-libinput/APKBUILD
+++ b/main/xf86-input-libinput/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-input-libinput
-pkgver=0.27.0
+pkgver=0.27.1
pkgrel=0
pkgdesc="X.Org input driver based on libinput"
url="http://xorg.freedesktop.org"
@@ -9,12 +9,11 @@ arch="all"
license="MIT"
depends=""
depends_dev="libinput-dev xorg-server-dev"
-makedepends="$depends_dev resourceproto scrnsaverproto eudev-dev"
+makedepends="$depends_dev eudev-dev resourceproto scrnsaverproto"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
- 0001-Fix-left-handed-property-not-set-on-all-pointers.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
./configure \
@@ -37,5 +36,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="716a9b43438acd6b7c6a834a08ecec244fecdc31e77241998414bf1748781026cd6c6e85947155c44400e0192769a714dfbfa0ed42ba3677347cd89ac1081743 xf86-input-libinput-0.27.0.tar.bz2
-4eda5ac30bcba9796e96c78e1b1f5da78b56c4edd72627e9518b492b586adbf190382b3cc0710ab9e9497f5ed1e97f78c1674436bb12e23b33a0f92d6058a4c5 0001-Fix-left-handed-property-not-set-on-all-pointers.patch"
+sha512sums="01379f5d71bf39214c4dff428173512df57fd12e782f3fcde757be923aa0dbf4e010a0395a81bd8e4fb518edc7e05ca1ee64b1e313eb4df5d4990315580609a1 xf86-input-libinput-0.27.1.tar.bz2"