aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch (renamed from unmaintained/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch)19
-rw-r--r--testing/pulseaudio/APKBUILD (renamed from unmaintained/pulseaudio/APKBUILD)38
-rw-r--r--testing/pulseaudio/pulseaudio.confd (renamed from unmaintained/pulseaudio/pulseaudio.confd)0
-rw-r--r--testing/pulseaudio/pulseaudio.initd (renamed from unmaintained/pulseaudio/pulseaudio.initd)0
4 files changed, 23 insertions, 34 deletions
diff --git a/unmaintained/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch b/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
index 22f524313d..15933931bc 100644
--- a/unmaintained/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
+++ b/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
@@ -14,13 +14,13 @@ Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
src/utils/padsp.c | 15 +++++++++------
- 1 file changed, 9 insertions(+), 6 deletions(-)
+ 1 file changed, 9 insertions(+), 6 deletions(-)
diff --git a/src/utils/padsp.c b/src/utils/padsp.c
-index e61373c..684721a 100644
---- src/utils/padsp.c
-+++ src/utils/padsp.c
-@@ -2368,7 +2368,7 @@ fail:
+index 943479b..d0530d7 100644
+--- a/src/utils/padsp.c
++++ b/src/utils/padsp.c
+@@ -2377,7 +2377,7 @@ fail:
return ret;
}
@@ -29,7 +29,7 @@ index e61373c..684721a 100644
int ioctl(int fd, int request, ...) {
#else
int ioctl(int fd, unsigned long request, ...) {
-@@ -2508,10 +2508,13 @@ int stat(const char *pathname, struct stat *buf) {
+@@ -2517,10 +2517,13 @@ int stat(const char *pathname, struct stat *buf) {
return 0;
}
@@ -45,7 +45,7 @@ index e61373c..684721a 100644
struct stat oldbuf;
int ret;
-@@ -2544,7 +2547,7 @@ int stat64(const char *pathname, struct stat64 *buf) {
+@@ -2553,7 +2556,7 @@ int stat64(const char *pathname, struct stat64 *buf) {
return 0;
}
@@ -54,7 +54,7 @@ index e61373c..684721a 100644
int open64(const char *filename, int flags, ...) {
va_list args;
mode_t mode = 0;
-@@ -2670,8 +2673,8 @@ FILE* fopen(const char *filename, const char *mode) {
+@@ -2679,8 +2682,8 @@ FILE* fopen(const char *filename, const char *mode) {
}
#ifdef HAVE_OPEN64
@@ -65,6 +65,3 @@ index e61373c..684721a 100644
debug(DEBUG_LEVEL_VERBOSE, __FILE__": fopen64(%s)\n", filename?filename:"NULL");
---
-2.1.4
-
diff --git a/unmaintained/pulseaudio/APKBUILD b/testing/pulseaudio/APKBUILD
index 8885170df9..55862e9fbd 100644
--- a/unmaintained/pulseaudio/APKBUILD
+++ b/testing/pulseaudio/APKBUILD
@@ -2,16 +2,15 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=pulseaudio
-pkgver=8.0
+pkgver=9.0
pkgrel=0
pkgdesc="A featureful, general-purpose sound server"
url="http://www.freedesktop.org/wiki/Software/PulseAudio"
arch="all"
license="LGPL"
-depends=""
-depends_dev="libcap-dev json-c-dev libsndfile-dev dbus-dev alsa-lib-dev tdb-dev
- speexdsp-dev sbc-dev bluez-dev jack-dev avahi-dev openssl-dev eudev-dev"
-makedepends="$depends_dev automake autoconf m4 intltool libtool bash"
+makedepends="m4 automake libtool intltool bash
+ dbus-dev libcap-dev alsa-lib-dev bluez-dev speexdsp-dev avahi-dev openssl-dev eudev-dev
+ libsndfile-dev gtk+3.0-dev json-c-dev fftw-dev gconf-dev sbc-dev jack-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bluez
$pkgname-alsa $pkgname-utils $pkgname-jack $pkgname-zeroconf $pkgname-system
@@ -21,19 +20,10 @@ source="http://freedesktop.org/software/pulseaudio/releases/pulseaudio-$pkgver.t
$pkgname.initd
$pkgname.confd"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -41,14 +31,16 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
+ --enable-bluez5 \
--disable-bluez4 \
--disable-nls \
+ --disable-orc \
|| return 1
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
}
@@ -133,15 +125,15 @@ zshcomp() {
mv "$pkgdir"/usr/share/zsh "$subpkgdir"/usr/share
}
-md5sums="8678442ba0bb4b4c33ac6f62542962df pulseaudio-8.0.tar.xz
-be814e7c1f53062f1a506c71a97dd6cb 0001-padsp-Make-it-compile-on-musl.patch
+md5sums="da7162541b3a9bc20576dbd0d7d1489a pulseaudio-9.0.tar.xz
+9c04ae15da7464e3d0003840b9025eed 0001-padsp-Make-it-compile-on-musl.patch
884cb9a843361844904e8c85542e72fb pulseaudio.initd
bf7487ba2c48fc8a56bca41c97a18934 pulseaudio.confd"
-sha256sums="690eefe28633466cfd1ab9d85ebfa9376f6b622deec6bfee5091ac9737cd1989 pulseaudio-8.0.tar.xz
-1c0ffd3a95b4bc65b97bd8bc6cca0fce386cecf2807e96ddd146521b47003004 0001-padsp-Make-it-compile-on-musl.patch
+sha256sums="c3d3d66b827f18fbe903fe3df647013f09fc1e2191c035be1ee2d82a9e404686 pulseaudio-9.0.tar.xz
+bfa722e400ba820ee7013ceb050058b4e239b1ea8544be23767ceb70ee0bc332 0001-padsp-Make-it-compile-on-musl.patch
bbd37d052962ddbf6ae633e4e3896da292d3e916a9123558a9b973096dda842d pulseaudio.initd
c03661e8cc902d27ff6b52f291207f2b008957571b942abdd92a873a52aae0dd pulseaudio.confd"
-sha512sums="7008abf768f720839353038ffd3e35e442f82452aa7e27d446f75d403096b042643d2b2b1d153454302bd5a51f9217f4979c8995b80ba2695f141e6a29e164fa pulseaudio-8.0.tar.xz
-0542ade084625e278bf1efdf4a72ed282e4876e98a7358d3c2746659ac3cac4098850468447b6018413022ee7dc085ac2ef34cc661d88e1d150a920cfcf79620 0001-padsp-Make-it-compile-on-musl.patch
+sha512sums="2177d4ab2ab7ded43d6eb5ece763504bdd614f9bdc27ab007894f8f7eed3fd0006a5b7550e5fd099d1877423524bc2baa22775372c8cefd9b772c28134d3e55a pulseaudio-9.0.tar.xz
+25b648681d9397631138635c024b5c6e289e32f11bf222afe4d853f62501555b5d75cc9058023d24ab8f97e442bcb37a647667e01582539d146762912a8ce08e 0001-padsp-Make-it-compile-on-musl.patch
34fe54ece5df60ce63a7955cd828a2716670fef71f40960698ae5518fdaf9cd599f4d8f8852e2c88d715600a9ad06a38984415e5eb320071012e5eb6e5c1b8b1 pulseaudio.initd
75b54581591519d63a3362b155c0f9b0501a60763ab394693a456c44d0216138cf3a40bdd0f7442028663bc045e9ffee286f8f8eaf2ee3bb17379b43615fee0e pulseaudio.confd"
diff --git a/unmaintained/pulseaudio/pulseaudio.confd b/testing/pulseaudio/pulseaudio.confd
index 1d31d342a0..1d31d342a0 100644
--- a/unmaintained/pulseaudio/pulseaudio.confd
+++ b/testing/pulseaudio/pulseaudio.confd
diff --git a/unmaintained/pulseaudio/pulseaudio.initd b/testing/pulseaudio/pulseaudio.initd
index 6dc11bf82b..6dc11bf82b 100644
--- a/unmaintained/pulseaudio/pulseaudio.initd
+++ b/testing/pulseaudio/pulseaudio.initd