aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/xclock/APKBUILD25
1 files changed, 5 insertions, 20 deletions
diff --git a/community/xclock/APKBUILD b/community/xclock/APKBUILD
index 9f44b27241..8a718e6c03 100644
--- a/community/xclock/APKBUILD
+++ b/community/xclock/APKBUILD
@@ -7,24 +7,12 @@ pkgdesc="Clock for the X Window System"
url="http://www.x.org"
arch="all"
license="MIT"
-depends=""
-depends_dev=""
makedepends="libx11-dev libxft-dev libxrender-dev libxaw-dev
libxkbfile-dev libxmu-dev"
-install=""
subpackages="$pkgname-doc"
source="http://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$_builddir"
@@ -32,16 +20,13 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --datarootdir=/usr/share \
- || return 1
- make || return 1
+ --datarootdir=/usr/share
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="6f150d063b20d08030b98c45b9bee7af xclock-1.0.7.tar.bz2"
-sha256sums="23ceeca94e3e20a6c26a703ac7f789066d4517f8d2cb717ae7cb28a617d97dd0 xclock-1.0.7.tar.bz2"
sha512sums="56689bdae6c83e9e1da5c4c48cf1136ca8b4f45b177f27bc1deeb24758e2c180035b639e8df72e3ebf32dc301bceb59118309fcce2ffab54e5abe9bfa645e607 xclock-1.0.7.tar.bz2"