aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/mesa/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 91b675c03d..5790b8abab 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=10.5.6
-pkgrel=0
+pkgrel=1
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
arch="all"
@@ -59,6 +59,8 @@ build() {
cd "$_builddir"
[ "$CLIBC" = "musl" ] && export CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700"
+ # set the minimum arch for x86 to prevent atmomic linker errors
+ [ "$CARCH" = "x86" ] && export CFLAGS="$CFLAGS -march=i586 -mtune=generic"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \