aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/tcsh/001-sysmalloc.patch (renamed from testing/tcsh/001-sysmalloc.patch)0
-rw-r--r--community/tcsh/002-test_123-posix_fix.patch34
-rw-r--r--community/tcsh/APKBUILD (renamed from testing/tcsh/APKBUILD)25
-rw-r--r--community/tcsh/tcsh.post-install (renamed from testing/tcsh/tcsh.post-install)0
l---------community/tcsh/tcsh.post-upgrade (renamed from testing/tcsh/tcsh.post-upgrade)0
-rw-r--r--community/tcsh/tcsh.pre-deinstall (renamed from testing/tcsh/tcsh.pre-deinstall)0
6 files changed, 51 insertions, 8 deletions
diff --git a/testing/tcsh/001-sysmalloc.patch b/community/tcsh/001-sysmalloc.patch
index b22c018983..b22c018983 100644
--- a/testing/tcsh/001-sysmalloc.patch
+++ b/community/tcsh/001-sysmalloc.patch
diff --git a/community/tcsh/002-test_123-posix_fix.patch b/community/tcsh/002-test_123-posix_fix.patch
new file mode 100644
index 0000000000..6ed59de387
--- /dev/null
+++ b/community/tcsh/002-test_123-posix_fix.patch
@@ -0,0 +1,34 @@
+Author: Dan Theisen <djt@hxx.in>
+Date: Wed Jun 06 03:30:25 2018 -0800
+
+The following lines have a subtle change around [:blank:], changing it
+to [[:blank:]] instead. This is required because POSIX treats characters
+inside of brackets as a group of characters to match against. In this case,
+[[:space:]] means [] group of characters, and [:space:] is the group, as per:
+IEEE Std 1003.1-2017 (Revision of IEEE Std 1003.1-2008), Chapter 9
+http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/V1_chap09.html
+
+--- tcsh-6.20.00/tests/lexical.at.old 2018-06-06 02:20:16.787145186 -0700
++++ tcsh-6.20.00/tests/lexical.at 2018-06-06 02:21:09.537890842 -0700
+@@ -567,10 +567,10 @@
+ ]])
+ AT_DATA([uniformity_test.csh],
+ [[
+-set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
++set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
+ echo -n "$SERVICE_NAME_LOG" > ./output1
+
+-cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
++cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
+
+ diff -uprN ./output1 ./output2 >& /dev/null
+
+@@ -587,7 +587,7 @@
+ echo "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP\)(HOST=db\)(PORT=1521\)\)(CONNECT_DATA=(SERVER=DEDICATED\)(SERVICE_NAME=bns03\)\)\)" > ./expected_result
+
+ set string = "jdbc_url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=db)(PORT=1521))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=bns03)))"
+-set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
++set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
+
+ echo "$SERVICE_NAME_LOG" > ./actual_result
+
diff --git a/testing/tcsh/APKBUILD b/community/tcsh/APKBUILD
index 3c713ab412..2e6e2ebc67 100644
--- a/testing/tcsh/APKBUILD
+++ b/community/tcsh/APKBUILD
@@ -1,19 +1,22 @@
-# Contributor:
-# Maintainer:
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=tcsh
pkgver=6.20.00
pkgrel=2
pkgdesc="extended C-shell"
url="http://www.tcsh.org"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
depends=""
+checkdepends="diffutils autoconf"
makedepends="ncurses-dev"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
-source="ftp://ftp.astron.com/pub/tcsh/${pkgname}-${pkgver}.tar.gz
- 001-sysmalloc.patch"
-builddir="$srcdir/tcsh-$pkgver"
+options="!checkroot"
+source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/t/tcsh/${pkgname}_${pkgver}.orig.tar.gz
+ 001-sysmalloc.patch
+ 002-test_123-posix_fix.patch"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -24,10 +27,15 @@ build() {
--bindir=/bin \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --disable-nls
+ --disable-rpath
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
@@ -35,4 +43,5 @@ package() {
}
sha512sums="c5635393c22341e62fb9a0b953ddf8871a876ab09deb08c98237f93afa9257b4a3381d1db65eefe769e22ef845db29ab7bc78773f1f609d73c8205689a6683e9 tcsh-6.20.00.tar.gz
-40149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch"
+40149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch
+b4c1afe04554d117b1402608bcdb243148c0c7b2442bdc10dde3ed6601db5e7c5a2341373f9bdc31fda8860e47a6e152cdcc4e3a8b273742037eebc624df282c 002-test_123-posix_fix.patch"
diff --git a/testing/tcsh/tcsh.post-install b/community/tcsh/tcsh.post-install
index 7342c5e721..7342c5e721 100644
--- a/testing/tcsh/tcsh.post-install
+++ b/community/tcsh/tcsh.post-install
diff --git a/testing/tcsh/tcsh.post-upgrade b/community/tcsh/tcsh.post-upgrade
index 180542a18b..180542a18b 120000
--- a/testing/tcsh/tcsh.post-upgrade
+++ b/community/tcsh/tcsh.post-upgrade
diff --git a/testing/tcsh/tcsh.pre-deinstall b/community/tcsh/tcsh.pre-deinstall
index 9e2e34c1c5..9e2e34c1c5 100644
--- a/testing/tcsh/tcsh.pre-deinstall
+++ b/community/tcsh/tcsh.pre-deinstall