aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/ocaml-migrate-parsetree/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/ocaml-migrate-parsetree/APKBUILD b/testing/ocaml-migrate-parsetree/APKBUILD
index c59dd8127b..df11701f81 100644
--- a/testing/ocaml-migrate-parsetree/APKBUILD
+++ b/testing/ocaml-migrate-parsetree/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-migrate-parsetree
pkgver=1.0.7
-pkgrel=0
+pkgrel=1
pkgdesc="Convert OCaml parsetrees between different major versions"
url="https://github.com/ocaml-ppx/ocaml-migrate-parsetree"
arch="all !x86 !armhf !s390x" # limited by ocaml
@@ -35,10 +35,11 @@ package() {
find usr/lib/ocaml -name '*.cmxs' -exec chmod 0755 {} \;
- # Remove compiled tests and some generated code (?).
+ # Remove annotation files, sources and some generated code (?).
find usr/lib/ocaml \
-name '*.cmt' -delete \
-o -name '*.cmti' -delete \
+ -o -name '*.ml' -delete \
-o -name '*.ml-gen' -delete
# Move docs to proper location and remove redundant docs dir.
@@ -59,7 +60,6 @@ dev() {
local path; for path in $(find $sitelib*/ \
-name '*.cmx' \
-o -name '*.cmxa' \
- -o -name '*.ml' \
-o -name '*.mli')
do
mkdir -p "${path%/*}"