aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/nanomsg/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/testing/nanomsg/APKBUILD b/testing/nanomsg/APKBUILD
index 00239447a0..5f43eabd45 100644
--- a/testing/nanomsg/APKBUILD
+++ b/testing/nanomsg/APKBUILD
@@ -1,28 +1,26 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nanomsg
-pkgver=1.1.0
+pkgver=1.1.2
pkgrel=0
pkgdesc="A socket library that provides several common communication patterns"
url="http://nanomsg.org/"
arch="all"
license="MIT"
-depends=""
depends_dev="asciidoctor xmlto"
makedepends="$depends_dev cmake"
-install=""
options="libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib .
- make || return 1
+ make
}
package() {
@@ -31,4 +29,4 @@ package() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha512sums="2d7d4b36e5c50cb7590e7dec0c271a021f05478cadeced6b5c9e27b76c3c5b59a11318c70b51e10efed6be2681dea7881a2f883f576fa5343c2aecfa18cbee50 nanomsg-1.1.0.tar.gz"
+sha512sums="f95ce24b34c25d139cf3de46585f6354e0311a9d5e7135ad71df62b8bb5df26f81a58b9773c39c320df2d0e97cd2905a8576f9f00b0a4d33774f1b610271cee5 nanomsg-1.1.2.tar.gz"