aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/check/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/main/check/APKBUILD b/main/check/APKBUILD
index ad9506c80d..1aa9a12719 100644
--- a/main/check/APKBUILD
+++ b/main/check/APKBUILD
@@ -2,15 +2,13 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=check
pkgver=0.12.0
-pkgrel=0
+pkgrel=1
pkgdesc="A unit test framework for C"
url="https://libcheck.github.io/check/"
arch="all"
license="LGPL2+"
makedepends="pkgconfig"
-# https://github.com/libcheck/check/issues/138
-options="!check"
-checkdepends="diffutils"
+checkdepends="diffutils gawk"
subpackages="$pkgname-doc $pkgname-dev"
source="https://github.com/libcheck/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
@@ -18,13 +16,16 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
+ # NOTE: disabled forking due to hardened
+ # https://github.com/libcheck/check/issues/138
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-fork
make
}