aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-zeroconf/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/testing/py-zeroconf/APKBUILD b/testing/py-zeroconf/APKBUILD
index 994a2c181d..4e9d7f95f9 100644
--- a/testing/py-zeroconf/APKBUILD
+++ b/testing/py-zeroconf/APKBUILD
@@ -3,21 +3,29 @@
pkgname=py-zeroconf
_pkgname=zeroconf
pkgver=0.19.1
-pkgrel=0
+pkgrel=1
pkgdesc="A Python implementation of multicast DNS service discovery"
url="https://github.com/jstasiak/python-zeroconf"
arch="noarch"
license="LGPL-2.0-or-later"
+# Tests require netlink support which is no present in AL
+options="!check"
depends="py-six py-netifaces"
-makedepends="python2-dev py-setuptools python3-dev"
+makedepends="python2-dev py-setuptools python3-dev py-netifaces py3-netifaces"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
}
package() {