aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libplist/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libplist/APKBUILD b/testing/libplist/APKBUILD
new file mode 100644
index 0000000000..f7ff87e6bd
--- /dev/null
+++ b/testing/libplist/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libplist
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="A library to handle Apple Property List format in binary or XML "
+url="http://www.libimobiledevice.org/"
+arch="all"
+license="GPL2 LGPL2.1"
+makedepends="automake autoconf libtool cython-dev"
+subpackages="$pkgname-dev py2-$pkgname:_py"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libimobiledevice/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ sh ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+_py() {
+ pkgdesc="Python2 bindings for $pkgname"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv $pkgdir/usr/lib/* "$subpkgdir"/usr/lib
+}
+
+sha512sums="a3534a585fd92cdcba552a8ec176d6da1d1c10b6639f9c01925e1de70689480b024a942f5686fcb0a356b450126e40aa3e2132ef66652806c46ee18a1d6372c8 libplist-2.0.0.tar.gz"