aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/i3wm/APKBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
index 87959f9dcd..187874e3eb 100644
--- a/community/i3wm/APKBUILD
+++ b/community/i3wm/APKBUILD
@@ -1,39 +1,39 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=i3wm
-pkgver=4.12
-pkgrel=1
+pkgver=4.13
+pkgrel=0
pkgdesc="A tiling window manager"
url="http://i3wm.org"
arch="all"
license="BSD"
-depends=""
-depends_dev=""
makedepends="$depends_dev bison flex libxcb-dev xcb-util-cursor-dev
xcb-util-keysyms-dev xcb-util-wm-dev libev-dev pango-dev cairo-dev
- yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev"
-install=""
+ yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev xcb-util-xrm-dev"
subpackages="$pkgname-doc"
source="http://i3wm.org/downloads/i3-${pkgver}.tar.bz2
musl.patch"
-builddir="$srcdir/i3-$pkgver"
+builddir="$srcdir/i3-$pkgver/"
+
build() {
cd "$builddir"
- make || return 1
+ ./configure --disable-builddir --prefix="/usr" --sysconfdir="/etc"
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./i3 --version
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir/" install || return 1
+ make DESTDIR="$pkgdir/" install
install -d "$pkgdir/usr/share/man/man1"
- install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/ || return 1
+ install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/
}
-md5sums="308fc79ed252e1f3c8a093598e13e326 i3-4.12.tar.bz2
-aa998beb0b9a83d2910508768ac7faae musl.patch"
-sha256sums="e19e1ce08c2549cba83e083cc768d487202c41760d5c283f67752e791f1d78b4 i3-4.12.tar.bz2
-b7d084c53addc71fda13ccb8b3dcca2a32d9ca1590a28bf3be1a0c61870d3817 musl.patch"
-sha512sums="966f62dbd82c6c70d1344cc61f14f154f3f649ce1b5a5b5168f00f50d598582ef26f5bd5496ea62e13213e45b1c7043f6209c94fcbefe2947fec63284445c1f5 i3-4.12.tar.bz2
+sha512sums="1bb1044e8d86e78d3ccb79d49f0eb26665dcd05a348058a5e57138151d74f57d77830efc3025893170fe1b8ec612f739f75247a427410f96286b09afd2c5f14c i3-4.13.tar.bz2
8ce7d00371c43b93dabbe0dadf9caf7c58a68f4a0079f5a9b9552c15c55bfa0df16d7e87a281595af2ac5254632ba28ccf82a467cea16159b41490f6f2910299 musl.patch"