aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/json-c/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/json-c/APKBUILD b/main/json-c/APKBUILD
index 467ad6790f..08a3918dd8 100644
--- a/main/json-c/APKBUILD
+++ b/main/json-c/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=json-c
pkgver=0.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="A JSON implementation in C"
url="https://github.com/json-c/json-c/wiki"
arch="all"
@@ -25,12 +25,15 @@ prepare() {
build() {
cd "$builddir"
./configure --prefix=/usr \
+ --build=$CBUILD \
+ --host=$CHOST \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--enable-shared \
- || return 1
+ ac_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_realloc_0_nonnull=yes
make -j1 || return 1
}