aboutsummaryrefslogtreecommitdiffstats
path: root/community/cargo
diff options
context:
space:
mode:
Diffstat (limited to 'community/cargo')
-rw-r--r--community/cargo/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/cargo/APKBUILD b/community/cargo/APKBUILD
index d4c096380e..db49123da2 100644
--- a/community/cargo/APKBUILD
+++ b/community/cargo/APKBUILD
@@ -2,13 +2,17 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=cargo
pkgver=0.25.0
-pkgrel=1
+pkgrel=2
pkgdesc="The Rust package manager"
url="https://crates.io"
arch="x86_64" # limited by rust pkg
license="MIT Apache-2.0"
depends="rust"
makedepends="cmake curl-dev libgit2-dev libssh2-dev libressl-dev python2 zlib-dev"
+# XXX: This is a hack to allow this abuild to depend on itself. Adding "cargo"
+# to makedepends would not work, because abuild implicitly removes $pkgname
+# and $subpackages from the abuild's dependencies.
+provides="cargo-bootstrap=$pkgver-r$pkgrel"
subpackages="$pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
$pkgname-zsh-completion:zshcomp:noarch"