aboutsummaryrefslogtreecommitdiffstats
path: root/community/dhcp-helper/compile-only-once.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/dhcp-helper/compile-only-once.patch')
-rw-r--r--community/dhcp-helper/compile-only-once.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/dhcp-helper/compile-only-once.patch b/community/dhcp-helper/compile-only-once.patch
new file mode 100644
index 0000000000..c35c6746e6
--- /dev/null
+++ b/community/dhcp-helper/compile-only-once.patch
@@ -0,0 +1,13 @@
+--- dhcp-helper-1.2.orig/Makefile
++++ dhcp-helper-1.2/Makefile
+@@ -5,7 +5,9 @@
+ CFLAGS?= -O2
+ version= $(shell ./get-version)
+
+-all: dhcp-helper.c
++all: dhcp-helper
++
++dhcp-helper: dhcp-helper.c
+ $(CC) $(CFLAGS) $(RPM_OPT_FLAGS) -DVERSION=\"$(version)\" -Wall -W dhcp-helper.c -o dhcp-helper
+
+ clean: