aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-lfs/makefile-extra_go_flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-lfs/makefile-extra_go_flags.patch')
-rw-r--r--community/git-lfs/makefile-extra_go_flags.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/git-lfs/makefile-extra_go_flags.patch b/community/git-lfs/makefile-extra_go_flags.patch
new file mode 100644
index 0000000000..16e2728906
--- /dev/null
+++ b/community/git-lfs/makefile-extra_go_flags.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -128,7 +128,7 @@
+ # It uses BUILD_MAIN as defined above to specify the entrypoint for building Git
+ # LFS.
+ BUILD = GOOS=$(1) GOARCH=$(2) \
+- $(GO) build \
++ $(GO) build $(EXTRA_GO_FLAGS) \
+ -ldflags="$(LD_FLAGS)" \
+ -gcflags="$(GC_FLAGS)" \
+ -o ./bin/git-lfs$(3) $(BUILD_MAIN)
+--- a/t/Makefile
++++ b/t/Makefile
+@@ -37,4 +37,4 @@
+ $(RM) $(TEST_CMDS)
+
+ ../bin/%$X : cmd/%.go
+- go build -o $@ $^
++ go build $(EXTRA_GO_FLAGS) -o $@ $^