aboutsummaryrefslogtreecommitdiffstats
path: root/community/gource/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gource/APKBUILD')
-rw-r--r--community/gource/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/gource/APKBUILD b/community/gource/APKBUILD
new file mode 100644
index 0000000000..486b40128f
--- /dev/null
+++ b/community/gource/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolistæ@alpinelinux.org>
+pkgname=gource
+pkgver=0.44
+pkgrel=0
+pkgdesc="Software version control visualization"
+url="http://gource.io/"
+arch="all"
+license="GPL3"
+depends=
+makedepends="ftgl-dev sdl2-dev sdl2_image-dev pcre-dev glew-dev libpng-dev
+ libjpeg-turbo-dev glu-dev boost-dev glm-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/acaudwell/Gource/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="b0f13a524e3391bfc41f12c624da1e00 gource-0.44.tar.gz"
+sha256sums="2604ca4442305ffdc5bb1a7bac07e223d59c846f93567be067e8dfe2f42f097c gource-0.44.tar.gz"
+sha512sums="4cdc7824f8f5b4aa7004135e59157ebf731730bc2dab0120ab919240576939b0e13dc6a09df79fcdb55cc7b4628c3887f5eca7ab0fa73d5e7bf5ad49c7cf898c gource-0.44.tar.gz"