aboutsummaryrefslogtreecommitdiffstats
path: root/community/irrlicht/irrlicht-1.8-optflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/irrlicht/irrlicht-1.8-optflags.patch')
-rw-r--r--community/irrlicht/irrlicht-1.8-optflags.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/community/irrlicht/irrlicht-1.8-optflags.patch b/community/irrlicht/irrlicht-1.8-optflags.patch
new file mode 100644
index 0000000000..07cba6e03c
--- /dev/null
+++ b/community/irrlicht/irrlicht-1.8-optflags.patch
@@ -0,0 +1,75 @@
+diff -up irrlicht-1.8/include/IrrCompileConfig.h.optflags irrlicht-1.8/include/IrrCompileConfig.h
+--- irrlicht-1.8/include/IrrCompileConfig.h.optflags 2012-11-05 15:14:14.000000000 -0500
++++ irrlicht-1.8/include/IrrCompileConfig.h 2012-11-13 12:45:47.316780394 -0500
+@@ -245,7 +245,7 @@ the engine will no longer read .jpeg ima
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
++// #define _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #undef _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #endif
+@@ -261,7 +261,7 @@ the engine will no longer read .png imag
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_
++// #define _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #ifdef NO_IRR_USE_NON_SYSTEM_LIB_PNG_
+ #undef _IRR_USE_NON_SYSTEM_LIB_PNG_
+ #endif
+@@ -598,7 +598,7 @@ ones. */
+ /** If this is commented out, Irrlicht will try to compile using the zlib
+ installed on the system. This is only used when _IRR_COMPILE_WITH_ZLIB_ is
+ defined. */
+-#define _IRR_USE_NON_SYSTEM_ZLIB_
++// #define _IRR_USE_NON_SYSTEM_ZLIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_ZLIB_
+ #undef _IRR_USE_NON_SYSTEM_ZLIB_
+ #endif
+@@ -619,7 +619,7 @@ library. */
+ /** If this is commented out, Irrlicht will try to compile using the bzlib
+ installed on the system. This is only used when _IRR_COMPILE_WITH_BZLIB_ is
+ defined. */
+-#define _IRR_USE_NON_SYSTEM_BZLIB_
++// #define _IRR_USE_NON_SYSTEM_BZLIB_
+ #ifdef NO_IRR_USE_NON_SYSTEM_BZLIB_
+ #undef _IRR_USE_NON_SYSTEM_BZLIB_
+ #endif
+diff -up irrlicht-1.8/source/Irrlicht/Makefile.optflags irrlicht-1.8/source/Irrlicht/Makefile
+--- irrlicht-1.8/source/Irrlicht/Makefile.optflags 2012-11-05 15:14:12.000000000 -0500
++++ irrlicht-1.8/source/Irrlicht/Makefile 2012-11-13 12:46:35.660811963 -0500
+@@ -56,18 +56,17 @@ BZIP2OBJ = bzip2/blocksort.o bzip2/huffm
+ EXTRAOBJ =
+ LINKOBJ = $(IRRMESHOBJ) $(IRROBJ) $(IRRPARTICLEOBJ) $(IRRANIMOBJ) \
+ $(IRRVIDEOOBJ) $(IRRSWRENDEROBJ) $(IRRIOOBJ) $(IRROTHEROBJ) \
+- $(IRRGUIOBJ) $(ZLIBOBJ) $(JPEGLIBOBJ) $(LIBPNGOBJ) $(LIBAESGM) \
+- $(BZIP2OBJ) $(EXTRAOBJ)
++ $(IRRGUIOBJ) $(EXTRAOBJ)
+
+ ###############
+ #Compiler flags
+-CXXINCS = -I../../include -Izlib -Ijpeglib -Ilibpng
+-CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1
+-CXXFLAGS += -Wall -pipe -fno-exceptions -fno-rtti -fstrict-aliasing
++CXXINCS = -I../../include `libpng-config --cflags`
++CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1 $(RPM_OPT_FLAGS)
++CXXFLAGS += $(RPM_OPT_FLAGS) -Wall -pipe -fno-exceptions -fno-rtti -fstrict-aliasing
+ ifndef NDEBUG
+ CXXFLAGS += -g -D_DEBUG
+ else
+-CXXFLAGS += -fexpensive-optimizations -O3
++CXXFLAGS += -fexpensive-optimizations -O3 $(RPM_OPT_FLAGS)
+ endif
+ ifdef PROFILE
+ CXXFLAGS += -pg
+@@ -88,7 +87,7 @@ STATIC_LIB = libIrrlicht.a
+ LIB_PATH = ../../lib/$(SYSTEM)
+ INSTALL_DIR = /usr/local/lib
+ sharedlib install: SHARED_LIB = libIrrlicht.so
+-sharedlib: LDFLAGS += -L/usr/X11R6/lib$(LIBSELECT) -lGL -lXxf86vm
++sharedlib: LDFLAGS += -L/usr/X11R6/lib$(LIBSELECT) -lGL -lXxf86vm -lz -ljpeg `libpng-config --libs` -lbz2
+ staticlib sharedlib: CXXINCS += -I/usr/X11R6/include
+
+ #OSX specific options