aboutsummaryrefslogtreecommitdiffstats
path: root/community/libx86emu/ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/libx86emu/ldflags.patch')
-rw-r--r--community/libx86emu/ldflags.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/libx86emu/ldflags.patch b/community/libx86emu/ldflags.patch
new file mode 100644
index 0000000000..de9ca775d9
--- /dev/null
+++ b/community/libx86emu/ldflags.patch
@@ -0,0 +1,13 @@
+Patch-Source: https://src.fedoraproject.org/rpms/libx86emu/blob/f27/f/libx86emu-1.11-ldflags.patch
+
+--- a/Makefile
++++ b/Makefile
+@@ -45,7 +45,7 @@
+ install -m 644 -D include/x86emu.h $(DESTDIR)/usr/include/x86emu.h
+
+ $(LIB_NAME): .depend $(OBJS)
+- $(CC) -shared -Wl,-soname,$(LIB_SONAME) $(OBJS) -o $(LIB_NAME)
++ $(CC) -shared -Wl,-soname,$(LIB_SONAME) $(LDFLAGS) $(OBJS) -o $(LIB_NAME)
+
+ test:
+ make -C test