aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ocaml/APKBUILD')
-rw-r--r--community/ocaml/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index 622eae5381..060239c084 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -55,13 +55,19 @@ package() {
LIBDIR="$pkgdir"/usr/lib/ocaml \
MANDIR="$pkgdir"/usr/share/man
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
+
+ cd "$pkgdir"
+
# Remove annotation files and sources.
- find "$pkgdir"/usr/lib/ocaml \
+ find usr/lib/ocaml \
\( -name '*.cmt' -o -name '*.cmti' -o -name '*.ml' \) \
-a -delete
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
+ # To be consistent with other binaries.
+ mv usr/bin/ocamldoc usr/bin/ocamldoc.byte
+ ln -s ocamldoc.opt usr/bin/ocamldoc
}
ocamldoc() {