aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk7
diff options
context:
space:
mode:
Diffstat (limited to 'community/openjdk7')
-rw-r--r--community/openjdk7/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index 2e8e7ff714..7ed5f10714 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -6,7 +6,7 @@ _icedteaver=2.6.7
# pkgver is <JDK version>.<JDK update>
# check icedtea JDK when updating
pkgver=7.111.$_icedteaver
-pkgrel=0
+pkgrel=1
pkgdesc="OpenJDK 7 via IcedTea"
url="http://icedtea.classpath.org/"
arch="all"
@@ -144,6 +144,7 @@ build() {
done
echo "icedtea patches: $DISTRIBUTION_PATCHES"
+ # --disable-arm32-jit: http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2942
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -156,6 +157,7 @@ build() {
--with-parallel-jobs=${JOBS:-2} \
--disable-dependency-tracking \
--disable-downloading \
+ --disable-arm32-jit \
--with-rhino=$srcdir/rhino$RHINO_VER/lib/rhino-$RHINO_VER.jar \
--with-openjdk-src-zip=$srcdir/openjdk-$_dropsver.tar.bz2 \
--with-hotspot-src-zip=$srcdir/hotspot-$_dropsver.tar.bz2 \