aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7/APKBUILD')
-rw-r--r--community/php7/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 60f1fdc7e8..78b05fad20 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -540,7 +540,8 @@ phar() {
_extension() {
local extname="${subpkgname#$pkgname-}"
local extdepends="$(eval "echo \$_depends_$extname")"
- pkgdesc="PHP$_suffix extension: $extname"
+ local extdesc="$(head -n1 "$builddir"/ext/$extname/CREDITS 2>/dev/null ||:)"
+ pkgdesc="PHP$_suffix extension: ${extdesc:-$extname}"
: ${extdepends:=$(_resolve_extension_deps "$extname")}
depends="$depends $extdepends"