aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-waitress
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-waitress')
-rw-r--r--community/py-waitress/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/community/py-waitress/APKBUILD b/community/py-waitress/APKBUILD
index 9822a343fa..b9bae46781 100644
--- a/community/py-waitress/APKBUILD
+++ b/community/py-waitress/APKBUILD
@@ -3,14 +3,14 @@
pkgname=py-waitress
_pkgname=waitress
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A Python WSGI server"
url="https://github.com/Pylons/waitress"
arch="noarch"
license="ZPL-2.1"
checkdepends="py-nose"
makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3 $pkgname-openrc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
waitress.initd
waitress.confd"
@@ -40,6 +40,11 @@ package() {
install -D -m 644 "$srcdir"/waitress.confd etc/conf.d/waitress
}
+openrc() {
+ default_openrc
+ depends="$pkgname=$pkgver-r$pkgrel"
+}
+
_py2() {
replaces="$pkgname"
_py python2