aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp-cors
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiohttp-cors')
-rw-r--r--community/py3-aiohttp-cors/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-aiohttp-cors/APKBUILD b/community/py3-aiohttp-cors/APKBUILD
new file mode 100644
index 0000000000..c47d80b1b7
--- /dev/null
+++ b/community/py3-aiohttp-cors/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-aiohttp-cors
+_pkgname=aiohttp_cors
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="CORS support for aiohttp"
+url="https://github.com/aio-libs/aiohttp-cors"
+arch="noarch"
+license="ASL 2.0"
+depends="py3-aiohttp"
+makedepends="python3-dev"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp-cors/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/aiohttp-cors-$pkgver
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0813ea48de714c85e361dfdaeef1a69526f7446dcc4ce637139cd333dedea58c635f85cfad1c3ccfb0df6e573f0351f282fdbd9726211d5915ed2ba120206b09 aiohttp_cors-0.5.3.tar.gz"