aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby2.2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby2.2/APKBUILD')
-rw-r--r--community/ruby2.2/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/ruby2.2/APKBUILD b/community/ruby2.2/APKBUILD
index f13df700d1..7b66978cd8 100644
--- a/community/ruby2.2/APKBUILD
+++ b/community/ruby2.2/APKBUILD
@@ -9,7 +9,7 @@ _abiver="$_majorver.0"
pkgrel=0
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
-arch="all !aarch64"
+arch="all"
license="Ruby"
depends=""
depends_dev="gmp-dev"
@@ -47,6 +47,7 @@ build() {
# In many places aliasing rules are broken; play it safe
# as it's risky with newer compilers to leave it as it is.
export CFLAGS="$CFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
+ export CPPFLAGS="$CPPFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
# ruby saves path to install. we want use $PATH
export INSTALL=install