aboutsummaryrefslogtreecommitdiffstats
path: root/community/snapcast/respect-optimization-level.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/snapcast/respect-optimization-level.patch')
-rw-r--r--community/snapcast/respect-optimization-level.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/snapcast/respect-optimization-level.patch b/community/snapcast/respect-optimization-level.patch
new file mode 100644
index 0000000000..614d9eee4c
--- /dev/null
+++ b/community/snapcast/respect-optimization-level.patch
@@ -0,0 +1,29 @@
+The value of the DEBUG variable is append to CXXFLAGS, thereby
+overwriting the optimization level set in the CXXFLAGS environment
+variable (-Os on alpine by default). Since we prefer to use our
+optimization level DEBUG needs to be unset.
+
+diff -upr snapcast-0.15.0.orig/client/Makefile snapcast-0.15.0/client/Makefile
+--- snapcast-0.15.0.orig/client/Makefile 2018-10-14 13:27:11.247287578 +0200
++++ snapcast-0.15.0/client/Makefile 2018-10-14 13:27:26.187330181 +0200
+@@ -31,7 +31,7 @@ else
+ endif
+
+ # Simplify building debuggable executables 'make DEBUG=-g STRIP=echo'
+-DEBUG=-O3
++DEBUG=
+
+
+ CXXFLAGS += $(ADD_CFLAGS) -std=c++0x -Wall -Wno-unused-function $(DEBUG) -DHAS_FLAC -DHAS_OGG -DASIO_STANDALONE -DVERSION=\"$(VERSION)\" -I. -I.. -isystem ../externals/asio/asio/include -I../externals/popl/include -I../externals/aixlog/include -I../externals -I../common
+diff -upr snapcast-0.15.0.orig/server/Makefile snapcast-0.15.0/server/Makefile
+--- snapcast-0.15.0.orig/server/Makefile 2018-10-14 13:27:11.257287607 +0200
++++ snapcast-0.15.0/server/Makefile 2018-10-14 13:27:18.830642536 +0200
+@@ -31,7 +31,7 @@ else
+ endif
+
+ # Simplify building debuggable executables 'make DEBUG=-g STRIP=echo'
+-DEBUG=-O3
++DEBUG=
+
+
+ CXXFLAGS += $(ADD_CFLAGS) -std=c++0x -Wall -Wno-unused-function $(DEBUG) -DHAS_FLAC -DHAS_OGG -DHAS_VORBIS -DHAS_VORBIS_ENC -DASIO_STANDALONE -DVERSION=\"$(VERSION)\" -I. -I.. -isystem ../externals/asio/asio/include -I../externals/popl/include -I../externals/aixlog/include -I../externals -I../common